Some strange behaviors after upgrade to v.0.4.1



  • Hi!

    I upgraded my installation to 0.4.1, and since then I have some problems that make my forum unusable:

    • User tools disappeared (I always see the "Login" link, even if I am authenticated)
    • browser tells me "Uncaught Reference error: require is not defined"
    • I can't create new topics (button doesn't react)
    • When I successfully log in I get redirected to a blank page with a JSON object: "Authentication successfull"
    • Tab title in browser is: "[[pages:]]"

    What I tried:

    • Installed nodebb from scratch
    • Cleared browser cache

    I run nodebb behind a nginx.
    Would be great if you can help me figure out what's happening 😄


  • GNU/Linux Admin

    @trixtan -- Best bet if this happens is to back up your database, and try ./nodebb reset. This will cause all plugins to de-activate, the theme to reset to Vanilla, and for all widgets to move into the Draft zone.

    If this renders your forum working again, then you'll have to re-enable plugins one-by-one to see what was the cause.



  • Hi Julian,,
    thanks for you hint.

    I tried with ./nodebb reset, but it doesn't seem to work. The program prints this:

    info: NodeBB v0.4.1 Copyright (C) 2013 DesignCreatePlay Inc.
    info: This program comes with ABSOLUTELY NO WARRANTY.
    info: This is free software, and you are welcome to redistribute it under certain conditions.
    info:
    warn: You have no mongo password setup!
    no match

    And stops. The only thing I can do is to kill -9 it...


  • GNU/Linux Admin

    Hey @trixtan sorry about that, try this: ./nodebb reset all



  • Hi Julian,

    thank you for the reply!
    Unfortunately, it didn't help... I wish I could give you more details, but I don't have any other feedback except the simptoms I already listed...

    Cheers

    E.



  • @trixtan can you update to latest and try again we just fixed a bug on mongo implementation. If you are getting any errors in the server console those would be useful as well.



  • It worked!!!

    • git pull -> nodebb upgrade -> start

    Thank you SO MUCH!


Log in to reply
 

Suggested Topics

| |