Register confirm urls in first email



  • Hey so I signed up a new user and got sent this:

    Screen Shot 2014-04-12 at 10.41.21 am.png

    I've setup config.json to use that base_url, but its still using the port. I'm using a Proxy in Nginx to serve nodebb from port 4680 on localhost, can I set use_port to false and still have things work that was and give correct urls on the emails? Or is this a bug?


  • GNU/Linux Admin

    Hey there @Ezra-Sharp

    You'll have to set use_port to off. That option just tells NodeBB to construct URLs with the port in it, like shown in that email 🙂



  • @julian

    If use_port is set to false, does that mean that proxy_pass in Nginx can do without the port in the URL?


  • GNU/Linux Admin

    @planner Even when use_port is set to false, NodeBB still listens on a port (that's how it works)

    So yes, you'll still need to have the port in the proxy pass URL, otherwise nginx won't know where to send requests destined for the NodeBB

    Remember, nginx is the reverse proxy server that handles a request that looks like linuxbsdos.com and sends it off to 127.0.0.1:4567



  • @julian

    That clears up a few things for me, thanks.


Log in to reply
 

Suggested Topics

| |