Site's not loading properly in Chromium

  • GNU/Linux Admin

    ... could your varnish cache is serving up old files? Toggle it off or flush its cache and let's see...


  • @julian

    If it is Varnish, it should be affecting FF too. But, yes, I'll flush it to see what happens.


  • Solved this problem, at least on the desktop.

    The problem is that Varnish has to be specially configured for WebSockets. So the site now loads smoothly on FF and Chromium, with no errors in the Web console. However, it still does not load properly on Android (Chrome). If anybody reading this has an iPad, please let me know whether forum.linuxbsdos.com loads properly.

    I'll post a tutorial on how to do it later tomorrow on my forum and post the link here.


  • similar situation, i'm looking at this


  • I solved the socket problem too , following the guide linked in my previous post. Varnish need some attention to work with sockets.

    @julian could you add this in nodebb wiki? the following are the settings that you need to add to your /etc/varnish/default.vcl to make varnish work with nodejs/nodebb

    backend nodebb {
      .host = "127.0.0.1"; # your app host
      .port = "4567"; # your app port
    }
    
    sub vcl_recv {
     
      # Pipe websocket connections directly to Node.js
      if (req.http.Upgrade ~ "(?i)websocket") {
        set req.backend = nodebb;
        return (pipe);
      }
    
      # NodeBB
      if (req.http.host == "forum.yourwebsite.com") { # change this
        if (req.url ~ "^/socket.io/") {
            set req.backend = nodebb;
            return (pipe); # return pass seems not working for websockets
        }
        return (pass); # don't cache
      }
     
    }
    
    sub vcl_pipe {
      # Need to copy the upgrade header
      if (req.http.upgrade) {
        set bereq.http.upgrade = req.http.upgrade;
      }
    }
    

    Now i have only 1 problem to solve and make v0.4.0 work:

    TypeError: template.match is not a function templates.js:101


  • @manuel

    That's slightly different from how mine is configured. But there are many ways to skin a cat. What's your site's URL?

  • GNU/Linux Admin

    @manuel -- For that error, you'll have to disable your widgets, as one or more of them seem to not be playing nicely.

    In Redis:

    keys widg*   # Should show four keys
    del {those four keys, each separated by a space}
    

    Or alternatively, in shell:

    $ redis-cli keys widg* | xargs redis-cli DEL

    Of course, back up your database first 😄


  • yahooo 👍
    all up & working finally ^_^

    i'll need to check plugins

  • GNU/Linux Admin

    @manuel 👍 I'm sorry it took so long! The bug was quite a peculiar one, should do a post-mortem shortly 🙂


  • @planner said:

    @manuel

    That's slightly different from how mine is configured. But there are many ways to skin a cat. What's your site's URL?

    I have created a page on NodeBB Wiki, update it if there is something wrong or to add

Suggested Topics

| |