PSA: Are you unable to install more than one plugin at a time?


  • Admin

    Just a quick note regarding node.js v8 and npm v5... these versions (which are now listed as recommended, stable, and LTS) change the way packages are handled, in that package installs are now saved to the local package.json file instead of installed locally only.

    What does this mean?

    If this affects you, then installing multiple plugins will result in only one plugin (the latest one) being available. In essence, every time you install a plugin, the other plugins you've installed before suddenly become uninstalled.

    What can I do?

    You can wait for us to patch this change in behaviour in a new release (likely v1.7.0, due out in two weeks' time).

    What else can I do?

    In a pinch, you can use the command line to install plugins, as they will add entries to package.json properly.

    For example, if you wanted to install both the "Two-Factor Authentication" plugin and the "SendGrid Emailer" plugin:

    npm i nodebb-plugin-emailer-sendgrid nodebb-plugin-2factor`
    

    What else?

    You can also downgrade npm by running the command npm i -g npm@4. Those problems will not be exhibited on those versions.

    We'll update this thread as new developments occur.


  • Admin

    Just a notice that the upcoming v1.7.0 of NodeBB will work fine with latest Node.js and npm.



  • Confirmed fix in 1.7.0


  • Admin

    @mudmanc4 Thanks!


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.