apache/nodebb issues

Technical Support
  • Hey there,

    I've set up nodebb with apache (Apache/2.4.25 Ubuntu)as the reverse proxy going by the instructions at https://docs.nodebb.org/configuring/proxies/apache/ .

    I'm using the minimal apache vhost configuration from that post, and I have the following mods enabled:

    Loaded Modules:
    core_module (static)
    so_module (static)
    watchdog_module (static)
    http_module (static)
    log_config_module (static)
    logio_module (static)
    version_module (static)
    unixd_module (static)
    access_compat_module (shared)
    alias_module (shared)
    auth_basic_module (shared)
    authn_core_module (shared)
    authn_file_module (shared)
    authz_core_module (shared)
    authz_host_module (shared)
    authz_user_module (shared)
    autoindex_module (shared)
    deflate_module (shared)
    dir_module (shared)
    env_module (shared)
    filter_module (shared)
    headers_module (shared)
    mime_module (shared)
    mpm_prefork_module (shared)
    negotiation_module (shared)
    php7_module (shared)
    proxy_module (shared)
    proxy_html_module (shared)
    proxy_http_module (shared)
    proxy_wstunnel_module (shared)
    reqtimeout_module (shared)
    rewrite_module (shared)
    setenvif_module (shared)
    status_module (shared)
    xml2enc_module (shared)

    As you can see all of


    are enabled. However I am getting a lot of these errors in the apache log:

    [Mon Oct 23 18:23:55.240861 2017] [proxy:error] [pid 4120] (111)Connection refused: AH00957: HTTP: attempt to connect to ( failed
    [Mon Oct 23 18:23:55.240894 2017] [proxy_http:error] [pid 4120] [client] AH01114: HTTP: failed to make connection to backend:, referer: http://<different nodebb URLs for my domain>

    Although in general the forum works users are complaining that at times they are getting the orange 'your connection has been dropped' boxes in nodebb.

    Any idea what's causing this issue?

  • @arkandel Make sure the URL listed in your config.json match the URL being used to navigate to the site.

  • @teh_g It does. I double checked just now.

    Any other ideas?

  • @arkandel The error mentions the loopback address. Make sure that resolves to the localhost? That would be my only other guess. Though if loopback was busted there would probably be more issues.

    Also, for sanity, really make sure the URL matches. https, www, etc all need to match. I had to setup a forward to send https://www.gamingexodus.com to

    since my URL value did not contain www in config.json.

  • @teh_g I had same issue . I fixed thank you ✌

  • thanks for the solution, issue is fixed now ☺

Suggested Topics