apache/nodebb issues

Technical Support
  • Hey there,

    I've set up nodebb with apache (Apache/2.4.25 Ubuntu)as the reverse proxy going by the instructions at https://docs.nodebb.org/configuring/proxies/apache/ .

    I'm using the minimal apache vhost configuration from that post, and I have the following mods enabled:

    Loaded Modules:
    core_module (static)
    so_module (static)
    watchdog_module (static)
    http_module (static)
    log_config_module (static)
    logio_module (static)
    version_module (static)
    unixd_module (static)
    access_compat_module (shared)
    alias_module (shared)
    auth_basic_module (shared)
    authn_core_module (shared)
    authn_file_module (shared)
    authz_core_module (shared)
    authz_host_module (shared)
    authz_user_module (shared)
    autoindex_module (shared)
    deflate_module (shared)
    dir_module (shared)
    env_module (shared)
    filter_module (shared)
    headers_module (shared)
    mime_module (shared)
    mpm_prefork_module (shared)
    negotiation_module (shared)
    php7_module (shared)
    proxy_module (shared)
    proxy_html_module (shared)
    proxy_http_module (shared)
    proxy_wstunnel_module (shared)
    reqtimeout_module (shared)
    rewrite_module (shared)
    setenvif_module (shared)
    status_module (shared)
    xml2enc_module (shared)

    As you can see all of


    are enabled. However I am getting a lot of these errors in the apache log:

    [Mon Oct 23 18:23:55.240861 2017] [proxy:error] [pid 4120] (111)Connection refused: AH00957: HTTP: attempt to connect to ( failed
    [Mon Oct 23 18:23:55.240894 2017] [proxy_http:error] [pid 4120] [client] AH01114: HTTP: failed to make connection to backend:, referer: http://<different nodebb URLs for my domain>

    Although in general the forum works users are complaining that at times they are getting the orange 'your connection has been dropped' boxes in nodebb.

    Any idea what's causing this issue?

  • @arkandel Make sure the URL listed in your config.json match the URL being used to navigate to the site.

  • @teh_g It does. I double checked just now.

    Any other ideas?

  • @arkandel The error mentions the loopback address. Make sure that resolves to the localhost? That would be my only other guess. Though if loopback was busted there would probably be more issues.

    Also, for sanity, really make sure the URL matches. https, www, etc all need to match. I had to setup a forward to send https://www.gamingexodus.com to https://gamingexodus.com since my URL value did not contain www in config.json.

  • @teh_g I had same issue . I fixed thank you ✌

  • thanks for the solution, issue is fixed now ☺

Suggested Topics

  • 0 Votes
    7 Posts

    @pitaj Yes true, I tried installing mongo onto my 17.04. The installation was successful but some packages did not work (were not supported).

  • 1 Votes
    4 Posts

    @oplik0 thanks a lot for the great explanation. I will update the topic later...

  • 0 Votes
    12 Posts

    I'm having this exact same problem currently-- ./nodebb dev works fine, ./nodebb start does nothing and outputs nothing to the logs, and I've tried all the ./nodebb upgrade and ./nodebb build.

  • 0 Votes
    2 Posts

    @avii try disabling all plugins. Make sure you have node v5+ installed.

  • Nodebb dont work

    Technical Support
    0 Votes
    17 Posts

    @PitaJ Yes i wrote in 2 post first of this.

    I installed version 1.1.0 but when im logged , the site was again freezed. For this i deleted dump.rdb from redis folder and i redid "./nodebb setup" to re-create the database. After i tried to re-create the bug, for this i uploaded the same "Image/Logo" and change "Site Title" . But no problems.
    Now seems work all perfecly.

    There is a urgent bug in 1.1.2 . I think that there is a bug in the database.
    I noticed that at the beginning , before of the bug in 1.1.2 , the cover of profile didn't worked, the users upload the image , but was invisible "all white". Worked only the avatar.
    In 1.1.0 this bug there isn't and at the beginning , the cover of profile worked.
    There is something broken in 1.1.2 .....