error after updating npm packages



  • I updated some of my npm packages on my forums, and am now getting an error when nodebb tries to start:

    
    NodeBB v1.4.5 Copyright (C) 2013-2014 NodeBB Inc.
    This program comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to redistribute it under certain conditions.
    For the full license, please visit: http://www.gnu.org/copyleft/gpl.html
    
    Clustering enabled: Spinning up 1 process(es).
    
    22/3 11:35:42 [1908] - verbose: * using configuration stored in: /var/www/nodebb/forums/config.json
    22/3 11:35:42 [1908] - info: Time: Wed Mar 22 2017 11:35:42 GMT-0400 (EDT)
    22/3 11:35:42 [1908] - info: Initializing NodeBB v1.4.5
    22/3 11:35:42 [1908] - verbose: * using redis store at 127.0.0.1:6379
    22/3 11:35:42 [1908] - verbose: * using themes stored in: /var/www/nodebb/forums/node_modules
    22/3 11:35:44 [1908] - verbose: Checking dependencies for outdated modules
    22/3 11:35:45 [1908] - verbose: [notifications.init] Registering jobs.
    22/3 11:35:45 [1908] - verbose: [user/jobs] (Re-)starting user jobs...
    22/3 11:35:45 [1908] - verbose: [user/jobs] 0 jobs terminated
    22/3 11:35:45 [1908] - verbose: [user/jobs] Starting job (digest.daily)
    22/3 11:35:45 [1908] - verbose: [user/jobs] Starting job (digest.weekly)
    22/3 11:35:45 [1908] - verbose: [user/jobs] Starting job (digest.monthly)
    22/3 11:35:45 [1908] - verbose: [user/jobs] Starting job (reset.clean)
    22/3 11:35:45 [1908] - verbose: [user/jobs] 4 jobs started
    22/3 11:35:45 [1908] - info: [themes] Using theme nodebb-theme-persona
    22/3 11:35:45 [1908] - error:  Error: [[error:theme-not-found]]
        at /var/www/nodebb/forums/src/meta/themes.js:148:21
        at /var/www/nodebb/forums/node_modules/async/dist/async.js:3694:9
        at /var/www/nodebb/forums/node_modules/async/dist/async.js:359:16
        at iterateeCallback (/var/www/nodebb/forums/node_modules/async/dist/async.js:864:24)
        at /var/www/nodebb/forums/node_modules/async/dist/async.js:843:16
        at /var/www/nodebb/forums/node_modules/async/dist/async.js:3691:13
        at apply (/var/www/nodebb/forums/node_modules/async/dist/async.js:21:25)
        at /var/www/nodebb/forums/node_modules/async/dist/async.js:56:12
        at /var/www/nodebb/forums/src/meta/themes.js:65:6
        at /var/www/nodebb/forums/node_modules/async/dist/async.js:1012:9
        at /var/www/nodebb/forums/node_modules/async/dist/async.js:359:16
        at replenish (/var/www/nodebb/forums/node_modules/async/dist/async.js:876:25)
        at /var/www/nodebb/forums/node_modules/async/dist/async.js:885:9
        at eachOfLimit (/var/www/nodebb/forums/node_modules/async/dist/async.js:912:22)
        at /var/www/nodebb/forums/node_modules/async/dist/async.js:917:16
        at eachOf (/var/www/nodebb/forums/node_modules/async/dist/async.js:990:5)
    [cluster] Child Process (1908) has exited (code: 0, signal: null)
    


  • I managed to fix it by deleting my packages.json file, replacing it with the version in github, then running npm install --production


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.