Solved - Installation Errors v1.4.3


  • Plugin & Theme Dev

    Hi guys,

    I'm doing an install of nodebb v1.4.3 on a clean new Ubuntu 16.04 server and following the instructions from:

    The instructions seem to be evolving nicely, but I ran into an error with he npm dependency installation:

    $ sudo npm install --production
    
    npm WARN deprecated mongodb@2.2.16: Please upgrade to 2.2.19 or higher
    npm WARN deprecated wrench@1.5.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra) for any operations you were using wrench for. Thanks for all the usage over the years.
    Killed          ...] | extract:passport-local: sill gunzTarPerm extractEntry less/bootstrap-rtl/pager-rtl.less
    
    
    $ sudo ./nodebb setup
    
    NodeBB could not be started because it's dependencies have not been installed.
    Please ensure that you have executed "npm install --production" prior to running NodeBB.
    
    For more information, please see: https://docs.nodebb.org/en/latest/installing/os.html
    
    Could not start: MODULE_NOT_FOUND
    

    Any advice?

    Thanks!


  • Plugin & Theme Dev

    Never mind, it was a simple memory issue that was causing npm install to die.

    Fixed with these instructions:


Log in to reply
 

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.