Trying to get NodeBB running on Flynn (open source PaaS)

Technical Support

Suggested Topics


  • 0 Votes
    4 Posts
    896 Views

    @zwarag that would have to be done with a custom plugin as well

  • 0 Votes
    8 Posts
    2k Views

    @teh_g after running npm i following error comes on console

    npm WARN deprecated [email protected]: connect 2.x series is deprecated
    npm WARN deprecated [email protected]: Use uuid module instead
    npm WARN deprecated [email protected]: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130
    npm ERR! Linux 3.10.0-693.11.1.el7.x86_64
    npm ERR! argv "/usr/bin/node" "/bin/npm" "i"
    npm ERR! node v6.12.0
    npm ERR! npm v3.10.10
    npm ERR! code ETARGET

    npm ERR! notarget No compatible version found: [email protected]
    npm ERR! notarget Valid install targets:
    npm ERR! notarget 0.3.6, 0.3.5, 0.3.4, 0.3.3, 0.3.1, 0.3.0, 0.2.0
    npm ERR! notarget
    npm ERR! notarget This is most likely not a problem with npm itself.
    npm ERR! notarget In most cases you or one of your dependencies are requesting
    npm ERR! notarget a package version that doesn't exist.

    npm ERR! Please include the following file with any support request:
    npm ERR! /home/pawan/Discussion forum/nodebb/npm-debug.log

    @julien

  • nginx reverse proxy nodebb

    Solved Technical Support
    4
    0 Votes
    4 Posts
    3k Views

    Yes, the url in config.json should be equal to exactly the URL at which you access your site. It usually shouldn't be localhost or an IP address.

  • 0 Votes
    9 Posts
    2k Views

    Have you tried run ./nodebb setup or ./nodebb build? It seems that it did't build the static files.

  • 0 Votes
    2 Posts
    2k Views

    I think to do this, you'd better hook "filter:post.upvote", check user's reputation, then return error info if not satisfied.
    This hook source code is at file socket.io/posts/helpers.js.

    See NodeBB how to do this for not-enough-reputation-to-downvote in src/posts/votes.js:

    if (command === 'downvote' && parseInt(results.reputation) < parseInt(meta.config['privileges:downvote'], 10)) { return callback(new Error('[[error:not-enough-reputation-to-downvote]]')); }