Help please, how uninstall nodebb-package-manager


  • GNU/Linux

    I`m install plugin nodebb-package-manager
    now ./nodebb upgrade have error

    root@debian:/webserver/forum/nodebb# ./nodebb upgrade

    1. Bringing base dependencies up to date...
      Error: Command failed: /usr/bin/env npm i --production
      npm ERR! Linux 3.16.0-4-amd64
      npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "i" "--production"
      npm ERR! node v6.9.1
      npm ERR! npm v3.10.9
      npm ERR! path /webserver/forum/nodebb/node_modules/nodebb-package-manager
      npm ERR! code EISGIT

    npm ERR! git /webserver/forum/nodebb/node_modules/nodebb-package-manager: Appears to be a git repo or submodule.
    npm ERR! git /webserver/forum/nodebb/node_modules/nodebb-package-manager
    npm ERR! git Refusing to remove it. Update manually,
    npm ERR! git or move it out of the way first.

    npm ERR! Please include the following file with any support request:
    npm ERR! /webserver/forum/nodebb/npm-debug.log

    How fix it?

    i can npm rm nodebb-package-manager

    Have error

    root@debian:/webserver/forum/nodebb/node_modules/nodebb-package-manager# npm rm nodebb-package-manager -D
    npm WARN nodebb-package-manager@0.0.0 license should be a valid SPDX license expression

    Help me please


  • GNU/Linux

    Hard fix
    I`m remove this folder from node_modules and upgrade nodebb..
    What was it?


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.