Errors when trying to bring base dependencies up to date



  • Is anyone else getting this error when pulling from master and running ./nodebb upgrade?

    ./Release/.deps/Release/obj.target/lwip_image/src/image/setpixel_worker.o.d.raw { dev: 45825,
      mode: 33188,
      nlink: 1,
      uid: 1000,
      gid: 1000,
      rdev: 0,
      blksize: 4096,
      ino: 412705,
      size: 1015,
      blocks: 8,
      atime: Sun Nov 01 2015 11:39:00 GMT+0000 (GMT),
      mtime: Sun Nov 01 2015 11:39:00 GMT+0000 (GMT),
      ctime: Sun Nov 01 2015 11:39:00 GMT+0000 (GMT) }
    npm ERR! Linux 3.8.11
    npm ERR! argv "node" "/usr/local/bin/npm" "i" "--production"
    npm ERR! node v0.10.40
    npm ERR! npm  v2.6.0
    npm ERR! code EPEERINVALID
    
    npm ERR! peerinvalid The package redisearch does not satisfy its siblings' peerDependencies requirements!
    npm ERR! peerinvalid Peer nodebb-plugin-dbsearch@0.2.17 wants redisearch@^0.0.5

  • Admin

    I've run into that problem before, this works for me:

    npm unl lwip
    npm unl redisearch
    npm i redisearch
    


  • Thanks @psychobunny 👍 That worked with a very slight amendment to the last command:

    npm unl lwip
    npm unl redisearch
    npm i redisearch@^0.0.5
    

    In case it's helpful, before doing that I was getting this error:

    npm ERR! peerinvalid Peer nodebb-plugin-dbsearch@0.2.17 wants redisearch@^0.0.5

Log in to reply
 

Suggested Topics

| |