Problem with WEBSOCKET - SSL


  • Gamers

    I have problem with WebSocket is my site.
    SSL is with CLOUDFLARE.
    In my server to redirect 46.101.143.115:4567 to https://schoolandschool.it i use NGINX .

    The error are.
    WebSocket connection to 'wss://schoolandschool.it/socket.io/?EIO=3&transport=websocket&sid=A04Bn2o2I0Pv25jBAAAY' failed: Error during WebSocket handshake: Unexpected response code: 400

    and more ......



  • Unless you have the enterprise plan on CloudFlare websocket is not supported.


  • Gamers

    @teh_g said:

    Unless you have the enterprise plan on CloudFlare websocket is not supported.

    SHIT.
    There is a method to redirect to a link without the SSL, the websocket?

    For now i have disabled SSL and deleted ruler with "Always use https " but It still redirects to https and not http ....


  • GNU/Linux

    I had this problem with Safari only. Chrome and Firefox don't see to mind it as long as you turn the orange cloud to grey. Also I setup a pagerule to disable all acceleration and caching but I'm still using strict SSL and don't get the polling errors anymore. (except in safari.. sigh)


Log in to reply
 


Star

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.