Twitter embed plugin


  • GNU/Linux

    I just started playing with this because I noticed it wasn't working... had a look at the code and @ the twitter url that the embed plugin uses.

    Noticed that there are 2 different url links with the words 'status' and 'statuses'.

    On seeing this I decided to change the word in the main regexp for this program.

    For some unexpected reason, after having so many problems trying to get this working again, changing the regexp and reloading NodeBB seemed to get the plugin displaying twitter embed's again. Can the plugin developer look at why this is working sometimes and not other times.

    After mucking around with it I decided to change this line to:

    var	regularUrl = /<a href="(http|https):\/\/twitter.com\/([^\/"\s]*)\/statuse?s?\/([^\/"\s]*)(\/photo\/1|)">.+?<\/a>/g
    

    note the ' statuse?s? ' (this matches either statuses or status in the url link)

    I know this probably worked correct before but for some strange reason altering this regexp seemed to kick start the plugin again and now it works.


 

| |