npm ERR! extraneous: redis@0.10.3



  • After checking out v0.5.x

    waterloo:NodeBB vlad$ npm ll

    npm ERR! extraneous: redis@0.10.3 /Users/vlad/workspace/nodebb/0.5.7/NodeBB/node_modules/redis
    npm ERR! extraneous: connect-redis@2.0.0 /Users/vlad/workspace/nodebb/0.5.7/NodeBB/node_modules/connect-redis
    npm ERR! extraneous: redis@0.10.3 /Users/vlad/workspace/nodebb/0.5.7/NodeBB/node_modules/redis
    npm ERR! not ok code 0

    SHouldn't redis package be an explicit dependency?



  • No, redis is only installed if you set it to use redis in setup.



  • @dwn Maybe that is the problem. I copied config.json from another workspace instead of running ./nodebb setup


  • Global Moderator

    @Baerrus the setup is what installs redis or mongo db, so yeah. You'll need to delete config.json and start at the setup command. :thumbsup:



  • I got it, now that I understand what installs redis.

    The way I upgrade is I create a brand new workspace, install a new version of nodebb, copy over the config.json. I think that makes sense in real deployment scenario versus executing "git pull" in place. This way I retain a fully functional prior version installation I can fall back to in a instant should something fail with a new version.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.