Installation problem



  • I have installed nodebb but can't use domain.com instead of domain.com:4567.Can anyone please help.When i installed installed node bb i used explorehowto.com as base url
    This is my config.json
    {
    "base_url": "http://explorehowto.com",
    "port": "4567",
    "secret": 'xxxxxxxxx",
    "bind_address": "0.0.0.0",
    "database": "redis",
    "redis": {
    "host": "127.0.0.1",
    "port": "6379",
    "password": "",
    "database": "0"
    },
    "bcrypt_rounds": 12,
    "upload_path": "/public/uploads",
    "use_port": false,
    "relative_path": ""
    }

    This is what i have inserted in
    cd /etc/nginx/sites-available/
    sudo nano explorehowto.com

    server {
    listen 80;

    server_name explorehowto.com;
    
    location / {
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header Host $http_host;
        proxy_set_header X-NginX-Proxy true;
    
        proxy_pass http://127.0.0.1:4567/;
        proxy_redirect off;
    
        # Socket.IO Support
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
    }
    

    }

    But it doesn't run on explorehowto.com but instead running on explorehowto.com:4567


  • Global Moderator

    @SANTO007

    sudo ln -s /etc/nginx/sites-available/explorehowto.com /etc/nginx/sites-enabled/

    sudo service nginx reload

    It appears you are also using Apache, you only need one, not both. Remove Apache if you're using nginx. Google will help you with removing Apache.



  • @a_5mith
    Did that but not working



  • @SANTO007 Look in your nginx.conf die to see it /etc/nginx/sites-enabled are in there as include path. Some installation are only having /etc/nginx/conf.d and then you will have to create the config file in that folder with .conf extension



  • here is the nginx.conf
    user www-data;
    worker_processes 1;
    pid /run/nginx.pid;

    events {
    worker_connections 768;
    # multi_accept on;
    }

    http {

    ##
    # Basic Settings
    ##
    
    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;
    
    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;
    
    include /etc/nginx/mime.types;
    default_type application/octet-stream;
    
    ##
    # Logging Settings
    ##
    
    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;
    
    ##
    # Gzip Settings
    ##
    
    gzip on;
    gzip_disable "msie6";
    
    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;
    
    ##
    # Virtual Host Configs
    ##
    
    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
    

    }

    #mail {
    # # See sample authentication script at:
    # # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript

    # # auth_http localhost/auth.php;
    # # pop3_capabilities "TOP" "USER";
    # # imap_capabilities "IMAP4rev1" "UIDPLUS";

    # server {
    # listen localhost:110;
    # protocol pop3;
    # proxy on;
    # }

    # server {
    # listen localhost:143;
    # protocol imap;
    # proxy on;
    # }
    #}


  • Global Moderator

    @SANTO007 You're still running Apache. your nginx won't work until you remove Apache.

    this is the default Apache homepage. Nginx looks like this

    Follow this guide. Be sure to stop Apache before running the remove packages.



  • OK, we have set it up again and now is running fine.




Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.