Not able to install the local mailer



  • I ran into the following errors when I attempted to install the local mailer.

    $npm install nodebb-plugin-emailer-local
    npm WARN package.json nodebb-plugin-dbsearch@0.0.15 No repository field.
    npm WARN package.json nodebb-plugin-wb-dbsearch@0.0.15 No repository field.
    npm WARN package.json reds@0.2.4 No repository field.
    npm ERR! peerinvalid The package nodebb-theme-vanilla does not satisfy its siblings peerDependencies requirements!
    npm ERR! peerinvalid Peer nodebb-theme-lavender@0.1.13 wants nodebb-theme-vanilla@~0.1.0
    npm ERR! peerinvalid Peer nodebb-theme-cerulean@0.0.13-2 wants nodebb-theme-vanilla@~0.0.13
    
    npm ERR! System Linux 3.16.5-x86_64-linode46
    npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install" "nodebb-plugin-emailer-local"
    npm ERR! cwd /<my_nodebb_path>/nodebb
    npm ERR! node -v v0.10.33
    npm ERR! npm -v 1.4.28
    npm ERR! code EPEERINVALID
    npm ERR! 
    npm ERR! Additional logging details can be found in:
    npm ERR!     /<my_nodebb_path>/nodebb/npm-debug.log
    

    Here are more detailed errors in the log.

    1535 info install nodebb-plugin-emailer-local@0.1.3
    1536 info postinstall nodebb-plugin-emailer-local@0.1.3
    1537 error peerinvalid The package nodebb-theme-vanilla does not satisfy its siblings peerDependencies requirements!
    1537 error peerinvalid Peer nodebb-theme-lavender@0.1.13 wants nodebb-theme-vanilla@~0.1.0
    1537 error peerinvalid Peer nodebb-theme-cerulean@0.0.13-2 wants nodebb-theme-vanilla@~0.0.13
    1538 error System Linux 3.16.5-x86_64-linode46
    1539 error command "/usr/bin/node" "/usr/bin/npm" "install" "nodebb-plugin-emailer-local"
    1540 error cwd /<my nodebb path>
    1541 error node -v v0.10.33
    1542 error npm -v 1.4.28
    1543 error code EPEERINVALID
    1544 verbose exit [ 1, true ]
    
    

    I have version 0.5.4 of nodebb.
    Recently, I also installed a few themes. Can this be an incompatibility issue? Any way to fix this?

    Thanks in advance!



  • I have version 0.5.4 of nodebb.
    Recently, I also installed a few themes. Can this be an incompatibility issue? Any way to fix this?

    I am answering to my question. It looks like the issue came from a theme I installed previously. It works fine after I do the following:

    npm uninstall nodebb-theme-cerulean
    

Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.