• Hello there.
    I just installed nodebb version NodeBB v0.5.0-4 on my debian box.
    I cannot authenticate for admin panel.
    I try different topics on the subject with no luck.
    I ran nodebb setup but the script never mention an admin account (only a password for the redis database and a 'Nodebb secret')

    I tried the nodebb secret as a password but nothing happens, i'm stuck with the message "Logging in" and that's it.
    Nothing interesting in the logs too.

    I use an ssh tunnel to redirect the traffic because i run nodebb on the localhost (don't think this is the problem).

    Thanks for your help.

  • GNU/Linux

    I presume you are able to get to the domain / IP and attempt log in.

    In terminal, try ./nodebb restart, this may help


  • Nope.
    I deactivated the ssh tunnel but i'm still stuck.
    As i'm a total noob on redis i still don't know what happens.
    The documentation is unclear about how to do such a simple thing 😞
    I'm surprised to be the only one who is stuck at this early stage, did i miss something?

    EDIT: got this message in nodebb log:
    info: NodeBB attempting to listen on: 0.0.0.0:4567
    info: NodeBB is now listening on: 0.0.0.0:4567
    info: [meta/css] Done.
    node_redis: no callback to send error: ERR unknown command 'pexpire'

  • GNU/Linux


  • Update redis to a higher version. Pexpire was introduced in redis 2.6.0. Google will help you update redis for your specific distro. Then stop Nodebb with./nodebb stop run the setup again, it should ask you to create an admin after you've gone through the settings (they should be saved from the first time you ran it) it will detect you have no admin account and set one up.

    Apologies for typos, auto correct to the rescue. :rage2:


  • Hello Guys,
    thanks for the answers.
    I tried to complety remove redis-server and reinstall it (purging conf files).
    Then the setup finally prompted me with questions for an admin account.
    But it fails as usual (pexpire in the logs).

    Then i updated the redis server to version 2.8.17.

    I finally managed to authenticated, but i have a blank page with:
    ""[[success:authentication-successful]]"

    And that's all!!
    What else?

    Another hint: it's very slow, and my admin account is often locked, wonder it there's no network problem.

    I didn't mention that i used nodebb with no frontal webserver, directly on port tcp 4567.

    EDIT: it finally works, have to remove /users/ from the url and i got the admin menu.
    There's no redirection to the main page after a sucessful login?


  • Make sure you're routing sockets.io correctly, or you'll end up on xhr-polling, I don't know what you use to route your site, but apache and nginx configs are here


  • @a_5mith
    I use no proxy web server for the moment.
    The nodebb forum is listen on port 4567 on my debian box.
    There is no routing to configure i guess (sorry total noob with node.js and redis)?
    I mean the proxy web is just for accessing the forum directly with no port number in the url (plus avoid the nodebb to listen on 0.0.0.0 but only on the loopback)?


  • @Julien-Deloubes can you provide more detail about the config.json?


  • @Julien-Deloubes This is just a guess about your situation based on my own initial setup of nodebb, but you may be having issues because of linux privileges (i.e. some stuff is done with sudo and some stuff isn't). So, try this and see if it helps:

    1. Go to the directory where your nodebb is installed and run sudo npm install
    2. Next type sudo chown -R youruser:youruser . <-- youruser is your username...
    3. Run ./nodebb setup
    4. Run ./nodebb dev and post any errors or warnings you get here...

    To summarize, you'll npm install with sudo because sometimes things need to rebuild which may call out to folders/files requiring su privileges. Then, you change ownership of your entire nodebb installation directory to your username to avoid privilege issues when running ./nodebb. You re-run setup to ensure things are built properly and where they need to be. Finally, ./nodebb dev will give you some useful output as nodebb loads and if you are having routing issues it will probably log those to the console as well. So, run it that way click around, type things and do stuff to see what happens and if you are getting errors/warnings post it here.

    Having said all that, I may be completely wrong, but it only takes a minute or two to try out and definitely won't mess things up. Just don't set your port to anything low (i.e.port 80) or you'll have issues because linux reserves the lower port numbers for su privileged users. Basically, stick to port 4567.

    Good luck!

Suggested Topics

| |