Error installing Redis in cloud9


  • GNU/Linux

    Wanted to test the latest build, so tried cloud9. successfully cloned the rep. But when tried to install redis , go this

    nada-nix install redis
    bash: nada-nix: command not found

    followed this guide : https://docs.nodebb.org/en/latest/installing/cloud/cloud9.html

    Any pointers ?



  • @meetdilip said:

    Wanted to test the latest build, so tried cloud9. successfully cloned the rep. But when tried to install redis , go this

    nada-nix install redis
    bash: nada-nix: command not found

    followed this guide : https://docs.nodebb.org/en/latest/installing/cloud/cloud9.html

    Any pointers ?

    Cloud9 have changed their service to offer sudo priveliges, so

    sudo apt-get install redis should work fine.

    Source: https://github.com/ajaxorg/cloud9/issues/3173


  • GNU/Linux

    @a_5mith

    meetdilip@lgs:~/workspace $ echo $IP
    0.0.0.0
    meetdilip@lgs:~/workspace $ npm install
    npm WARN package.json chat-example@0.0.0 No repository field.
    meetdilip@lgs:~/workspace $ node app --setup

    module.js:340
    throw err;
    ^
    Error: Cannot find module '/home/ubuntu/workspace/app'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:906:3
    meetdilip@lgs:~/workspace $



  • @meetdilip Not sure on that one. Will wait for someone else to chirp in with that solution. 👍


  • GNU/Linux

    Thanks for trying. 👍



  • I know this is old but it came up when I was looking for an answer, so for those that come after.....

    Redis is already on c9 and its old.
    Following is some quick instructions that get it working but please understand i REALLY DONT know what Im doing 😉
    The instructions are base off...

    Remove the old redis stuff
    Do you need to do this?...no idea 😉

    $ sudo service redis-server stop
    $ sudo dpkg -P redis-server
    $ sudo dpkg -P redis-tools
    

    Download and make the new Redis 3.0.x

    paez@nodebb:~/workspace $ mkdir redis
    $ cd redis
    wget http://download.redis.io/releases/redis-stable.tar.gz
    tar xzf redis-stable.tar.gz
    cd redis-stable
    make
    sudo make install
    

    Install
    During the install the default path for where to put the executable s was wrong and I think it was /usr/bin/
    Also, select port 16379, because the old redis is still running and Im still not sure how to turn it off properly. But your new one will work fine if you set nodeBB to the new one. I did get rid of it once, but not exactly sure how.

    cd utils
    sudo ./install_server.sh
    

    And now you should have a working redis on 0.0.0.0:16379.
    Still have the old one running, as I dont know how to get rid of it properly yet.

    I tested this with the latest NodeBB and was able to get it to work except I get this error in the console....

    WebSocket connection to 'ws://nodebb-c9-paez.c9.io/socket.io/?EIO=3&transport=websocket&sid=Gn4rDgj2XlEILV0FAAAA' failed: Error during WebSocket handshake: Unexpected response code: 400
    

    ...and a whole bunch of....
    [deprecated] variables.set is deprecated, please use ajaxify.data...
    ...dont know why and am not likely to find out as Im going to be running it off Openshift, but this hopefully gets someone a little closer....and it does seem to work good enough for theme mucking which is what I wanted the c9 one for.


Log in to reply
 

Suggested Topics

| |