Fresh Droplet, New Install, New Issues

Bug Reports
  • Perhaps this isn't a Nodebb bug, and perhaps just a config issue somewhere, but I launched a new droplet on Digital Ocean yesterday. In comparison to the previous droplet (which worked wonderfully) I've had a bit of bad luck with this instance.

    • NodeBB randomly disconnects, and it takes a couple of refreshes to get it back.
    • NodeBB logins don't fully redirect see this image. Imgur

    Has anyone been experiencing anything similar since the first public release candidate of 0.5?

  • Anything in ./nodebb log when it disconnects, you can either start nodebb then run the log and leave it open until it disconnects, or you can run nodebb dev and leave that screen open until you get disconnected. Should tell you why.

    I've seen the login error a few times, usually only happens the first time you log in though. Subsequent times are usually fine.

  • Based on the log it seems like every time NodeBB is refreshed or enters a page unaccessed before, NodeBB has to reinitialize. Is this normal?

  • @Ted It's not normal, no. 😆 Can you run ./nodebb stop then ./nodebb dev and keep an eye on that, it should give you more information on why it is reinitiali(z)sing.

  • @a_5mith, giving it a go now.
    Sorry for the late reply. A weekend of drinking with friends, and work is kicking off in full swing with the college kids returning. Makes things fun - yet hectic.

    The forum is now displaying a "The forum has been updated to the latest version" overlay in the top right - when I haven't updated anything. This issue continues. I went ahead and made sure that Cloudflare wasn't caching anything, as I use it for DNS.

    Ran nodebb in dev - seeing no alerts. One warn that the action:app.load hook is deprecated - but the rest seems normal.

    Edit 2:
    This doesn't occur all the time, but seems to be the culprit.

  • Do you have any groups added in your ACP that are empty.

    I recall seeing this issue a few weeks back. Recall @baris knew the fix.

  • @a_5mith, the only group is the admin group - and I'm filling that.

    Tried updating to the latest version, and the issue seems to persist.

  • As a follow up - I restored from snapshot and re-installed to correct the issue.

Suggested Topics