Problems with imgur plugin



  • I'm getting 404 errors from the admin page of the imgur plugin (nodebb-plugin-imgur). I'm running NodeBB 0.4.1 0.4.3. I believe this has something to do with a new method of creating routes, but I'm not sure what I can do about it.

    Any guidance?



  • Had the same problem with nodebb-plugin-emailer-local (fixed by installing a special version).
    Have the same problem with nodebb-plugin-sso-google and nodebb-plugin-sso-oath.

    Am I doing something wrong, or are things really this messy?



  • @Shaun Current Stable is 0.4.3, so you could upgrade to that, pretty sure the plugins work with that version still. I personally run Master and don't have any issues, but there's always that saying about varying mileage, it depends how custom your current build is in terms of mods and changes to templates you already have installed etc etc. A few of old plugins don't work past 0.4.3. (I don't know which ones) also 0.5.0 is expected soonish, which will become current stable. But, no definitive timeframe on that one.



  • Sorry. I lied. I'm running 0.4.3.

    It's a brand spankin' new, fresh, 100% clean and entirely uncustomized install (thus the reason I am having problems with like ... every plugin ever written).

    No customization whatsoever outside of modifications made within the ACP and those are mostly basic things (like changing categories, selecting a different set of Bootstrap swatches, etc - nothing that should affect plugin loading as far as I can tell).



  • I am (generally) installing these from the Plugins section of the ACP, but in the case of the imgur plugin, I have also tried installing from the command line with npm. I had the same problem with nodebb-plugin-emailer-local, as I mentioned, and the solution was to install from a specific git repository from the command line.

    It seems odd to me that simply installing all of these plugins fails (it's been literally every plugin I've installed so far except the search plugin), so I was kind of thinking I must be doing something wrong, but I can't tell what.



  • @Shaun If it's a brand new install, can you try the following to see if this fixes your issue.

    git checkout master
    git pull
    ./nodebb upgrade
    

    Master currently has no breaking issues, so it runs fine, when 0.5.0 comes out, you can then switch back over to stable, since master is almost 0.5.0 anyway.

    I assume you're using ubuntu with the above commands. Think it's a similar process for other distros.



  • @a_5mith I ❤ you.

    git checkout master said I was already on master, but the upgrade seems to have fixed the imgur plugin. Yes, this is on Ubuntu. So assuming 0.5.0 comes out and I want to upgrade, I run the same as above with checkout stable instead of checkout master?



  • @Shaun when 0.5.0 is released, their will be full documentation, but the process will be something along the lines of

    git checkout v0.5.x
    git pull
    ./nodebb upgrade
    

    But their will be an announcement about all of that and how to update when it's ready. If you have any other issues with plugins etc, feel free to create a topic. 👍


Log in to reply
 

Suggested Topics

| |