Install Nodebb with Apache



  • @a_5mith I install as other user with su privileges, and still this same. http://188.226.241.129:4567/login 😞



  • @Tomasz-Piątek

    Can you run

    ./nodebb stop
    ./nodebb dev 
    

    and paste the output. Where did you install it?



  • @a_5mith I install in /home/nodebb/nodebb/ (nodebb is user)

    dev output:

    Launching NodeBB in "development" mode.
    To run the production build of NodeBB, please use "forever".
    More Information: https://github.com/NodeBB/NodeBB/wiki/How-to-run-NodeBB
    info: NodeBB v0.4.3 Copyright (C) 2013-2014 NodeBB Inc.
    info: This program comes with ABSOLUTELY NO WARRANTY.
    info: This is free software, and you are welcome to redistribute it under certain conditions.
    info:
    info: Time: Tue Jun 24 2014 13:41:35 GMT+0000 (UTC)
    info: Initializing NodeBB v0.4.3
    info: * using configuration stored in: /home/nodebb/nodebb/config.json
    info: * using redis store at 127.0.0.1:6379
    info: * using themes stored in: /home/nodebb/nodebb/node_modules
    info: Base Configuration OK.
    info: [notifications.init] Registering jobs.
    info: [user.startJobs] Registering User Jobs
    info: Enabling 'trust proxy'
    info: [plugins] Initializing plugins system
    info: [themes] Using theme nodebb-theme-lavender
    info: Middlewares loaded.
    info: [plugins] Found 1 CSS file(s) for plugin nodebb-widget-essentials

    warn: [plugins/nodebb-plugin-mentions] This plugin may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing.
    warn: [plugins/nodebb-plugin-mentions] In the event of an unresponsive NodeBB caused by this plugin, run ./nodebb reset plugin="nodebb-plugin-mentions".

    info: [plugins] Found 1 LESS file(s) for plugin nodebb-plugin-mentions
    info: [plugins] Found 2 js file(s) for plugin nodebb-plugin-mentions
    info: [plugins] Found 1 LESS file(s) for plugin nodebb-plugin-markdown
    info: [plugins] Found 3 js file(s) for plugin nodebb-theme-lavender
    info: [plugins] Loaded plugin: nodebb-widget-essentials
    info: [plugins] Loaded plugin: nodebb-plugin-mentions
    info: [plugins] Loaded plugin: nodebb-plugin-soundpack-default
    info: [plugins] Loaded plugin: nodebb-plugin-markdown
    info: [plugins] Loaded plugin: nodebb-theme-lavender
    info: [plugins] Sorting hooks to fire in priority sequence
    info: [plugins] Plugins OK
    info: [meta/css] Minifying LESS/CSS
    info: [sounds] Sounds OK
    info: [themes] Compiling templates
    info: [themes] Successfully compiled templates.
    info: NodeBB attempting to listen on: 188.226.241.129:4567
    info: NodeBB is now listening on: 188.226.241.129:4567
    info: [meta/css] Done.
    info: [meta/js] Compilation complete
    info: NodeBB Ready



  • @Tomasz-Piątek Strange, same issue, post login aborts. :s

    cd ~
    redis-server --version
    

    Should see v=x.x.x

    What's there?



  • @a_5mith said:

    redis-server --version

    Redis server version 2.2.12 (00000000:0)

    node.js v0.10.28



  • @Tomasz-Piątek Ok now we're getting somewhere.

    sudo apt-get install -y python-software-properties
    sudo add-apt-repository -y ppa:rwky/redis
    sudo apt-get update
    sudo apt-get install -y redis-server
    

    Then restart your server and start nodebb with ./nodebb start.



  • @a_5mith when i start as dev i have error:

    error: NodeBB could not connect to your Redis database. Redis returned the following error: Redis connection to 127.0.0.1:6379 failed - connect ECONNREFUSED



  • Make sure Redis is running by doing

    cd ~
    redis-server
    

    Then go through the installation again by going to your nodebb folder and running ./nodebb setup make sure you leave password blank, as redis doesn't use one by default.



  • @a_5mith now stop in:

    info: Populating database with default configs, if not already set...

Log in to reply
 

Suggested Topics

  • 2
  • 8
  • 1
  • 2
  • 12
| |