Cannot open /admin page after upgrade

General Discussion
  • Today I upgraded to the latest nodebb, however, I found I cannot open /admin page...Any help? Thanks

    2021-11-14T00:27:37.696Z [4567/1475] - info: [api] Adding 0 route(s) to `api/v3/plugins`
    2021-11-14T00:27:37.737Z [4567/1475] - info: [router] Routes added
    2021-11-14T00:27:37.753Z [4567/1475] - info: NodeBB Ready
    2021-11-14T00:27:37.757Z [4567/1475] - info: Enabling 'trust proxy'
    2021-11-14T00:27:37.762Z [4567/1475] - info: NodeBB is now listening on:
    (node:1475) UnhandledPromiseRejectionWarning: Error: connect ECONNREFUSED
        at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1146:16)
        at TCPConnectWrap.callbackTrampoline (internal/async_hooks.js:131:14)
    (Use `node --trace-warnings ...` to show where the warning was created)
    (node:1475) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see (rejection id: 1)
    (node:1475) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
  • I used the following to stop Solr plugin, then rebuild, then it works.

    ./nodebb reset -p nodebb-plugin-solr

    I do remember that when I was upgrading nodebb, it said solr will be upgraded. Then I upgrade solr. But it looks the new version of solr doesnot work well, at least for my server.

    One year ago I met the problem of Solr, back then I installed solr manully. I am not sure if it is the same problem this time.

  • I tried to build it again, yes, once I install nodebb-solr by the following command, and active it in the ACP, then I cannot open /admin page.

    npm install nodebb-plugin-solr

    as soon as I remove it by

    npm uninstall nodebb-plugin-solr

    I can open ACP page. I am using nodebb v1.18.6. I find this solr plugin was updated recently from 5,3,0 to 5.3.1, I think maybe there is a bug?

    Alright, right now I use the following to fix it:

    npm install [email protected]

    Now it works.

Suggested Topics