Reload tab necessary to render



  • I've come across a problem where although I click a link (e.g., Plugin or setting in Admin) and the link is displayed in the Address Bar that I need to reload the tab or double-click the link for it to load. Tested in Chrome 34 and Firefox 30. This type of behavior is true of the main page, where categories will display but the widgets sometimes require a reload (not all the time) of the browser tab.

    Before
    Screen Shot 2014-05-18 at 6.03.35 PM.png
    After Tab Reload
    Screen Shot 2014-05-18 at 6.03.47 PM.png

    I'm behind an Apache proxy, setup using these instructions. I'm almost certain it's due to my Proxy config, but can use help troubleshooting. Here is the httpd error_log.



  • I'm using Nginx proxy with very little modification of the site, and get the same thing.

    If I click on a link or go back, one out of every 4-5 times the page won't load unless I reload it.

    Plus one user is unable to click on the "new topic" button, and it's reproducible on another computer.



  • @Kamal-Patel I had a user report the lack of a New Post button as well on the Vanilla theme. I had them log out and back in and it solved that.



  • @Guiri Cool thanks, I'll ask them to try that.



  • @Kamal-Patel, this bug wasn't due to NodeBB, it was due to using Apache. I switched to nginx and now the site is quite responsive and doesn't require double clicking of links or reloading of tabs. I suspect that I did not enable or compile Apache's websockets module correctly.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.