@pitaj Yes true, I tried installing mongo onto my 17.04. The installation was successful but some packages did not work (were not supported).