Thanks for all the help, turns out it was because I hadn't installed the dependencies for write-api 😑