Essentially, yes. We do not review the packages, and do a simple search for /^nodebb-(plugin|theme|widget).+ (though the exact regex is likely different).

We rely on plugin maintainers themselves to report plugin compatibility via the nbbpm.compatibility flag in package.json. A better system is planned, but not in development at the moment.