@jk4321 said:

If I set the port to 80 in config.json, we get no response at all.

It might be the case that another process is already listening on port 80. Many popular Linux distributions come with httpd (AKA: Apache) installed and enabled by default, so you could check if that or any other webservers (i.e. Nginx, Litespeed) are running.

If it's none of those processes, try doing a quick google search for "(name of your OS) port usage".