If package.json recommends a version of a bundled plugin, stick to that version. In your case, stick with v1.0.9.