Frontend freeze on version later than v1.0.2

  • GNU/Linux Admin

    Are any of you up for running git-bisect to determine which commit started causing these issues?

    Because it only seems to occur on your instances, we cannot reproduce it and find a fix 馃槮

    We're running master branch here, with no issues.

    That said, do these errors occur on master?

  • Swedes

    Yes, same issue at master!

  • @julian I have installed nodebb less than a couple of weeks ago. I got master branch. Perhaps this only happens with new installations?

    At this point the forums is useless :( sometimes it freezes after half an hour, sometimes it runs no problem for a few hours or a whole night.

    If I somehow can help you diagnose the problem, tell me what I can do.

  • Swedes

    I am updating my system right now and wondering what nodejs version is recommended. I see now that I use an old version of nodejs.

    0.12.6 <-- this is my old version
    4.4.1 <-- this is the one I will update to

    Release: Gentoo

    Maybe thats the reason :P I will try it out in a few days!

    @Diego-Bao Yes, indeed. > v1.0.2 is pretty useless hehe. Trashcan next in my case. Must find the issue ;) And NO, this has nothing todo with new installation. I having trouble with all my old installations. Upgrade breaks the db! And it seams to be broken even if i downgrade so plz backup before upgrade !

  • GNU/Linux Admin

    Can either of you send a database dump to me? (my username @

    Perhaps it will reproduce on my local environment... but without traffic, I doubt it...

  • Swedes

    Yes, I will try to use nodejs 4x first and if that dont work i then i can send files and db dump to you :) Traffic is not the issue in my case, no traffic but it still hangs :P

  • @julian Sorry I previously said I was running on master but I'm running on v1.x.x branch

  • Swedes

    I have it up and running again at v1.x.x branch

    • Mongo 2.6
    • Nodejs 4.4.1

    Lets see how long it takes before hell breaks out again :P

    Edit: Still running but even if this does not work its recommended to upgrade to Nodejs 4.4.1 :) Seams a lot faster :P

  • @Jenkler it shouldn't take long lately it just takes me half an hour to break.

  • Swedes

    Wiiii, it seams that the problem is solved for me. I will test more today but no crash since yesterday.

    The issue was with Nodejs 0.12.6, I upgraded to Nodejs 4.4.1 and now it works.

    Thanks for all input <3 I love NodeBB !

  • I upgraded to Nodejs 4.4.5 and running Nodebb v1.0.3 (master). in less that 30 mins it froze again.

  • I completely uninstall it and did a clean instalation of the code (left the dB alone). Installed version v1.0.2 and so far it's running fine.

    Only thing I noticed is that the notifications number in my user shows 1, when I don't have any notification. I mark all as read, but if I refresh the page I get 1 again. I will keep updating here if I have more issues.

  • Swedes

    Try 4.4.1 it works for me with v1.x.x

  • The problem with the user notification might be the issue I'm having. If I click to see the notification or unread messages the forum crashes and restarts on its own. But this only happens with my user.
    Well @julian has my DB, so he probably can figure it out what it's happeneing.

  • Hi All,

    Same issue here. Running on Ubuntu 16.04, node.js 4.4.5 and mongodb 2.6. Clean install from scratch (new forum). Everything works nice for about 30min then boom, Nodebb just crashes.... Nothing in Nodebb logs and nothing in MongodDB logs as well...

    I'm going crazy, I've checked almost everything... It's seems like a random behaviour and it crashes with or without activities...

    I've deactivated almost all the plugins... Didn't change anything :(

    Now I upgraded MongoDB to 3.0 and and changed the 2 kernel params

    ~$ cat /sys/kernel/mm/transparent_hugepage/enabled
    [always] madvise never
    ~$ cat /sys/kernel/mm/transparent_hugepage/defrag
    [always] madvise never

    It's still up for the moment (1h30). I'll keep you posted.

  • Well, it crashes again after 1h45 min :( Don't know what to do... Any advice?

  • Swedes

    My still work in docker! check my packages here!

    Running branch v1.x.x witch is v1.0.3 for now :)

  • @Jenkler I'm, unfortunately, not running on docker. I've upgraded MongoDB to 3.2. I've also figured out that my NodeBB user didn't had all the environments... Running for 2h now.... Crossing fingers.

  • Swedes

    Cool, I have almost updated all my forums now. I also hope the the issues is over :P

  • well still running for the moment...

Suggested Topics

| |