Frontend freeze on version later than v1.0.2

  • Swedes

    Nope, v1.x.x also crashes 😞 If I deactivate plugins are they gone from the process or can they still break things? Still troubleshooting .... seams to be something wrong with nodebb-plugin-custom-pages ....

  • Plugin & Theme Dev

    If deactivated they don't get loaded at all. So they can't break anything.

  • Swedes

    Ok, good 2 know. I am going insane over this issue. All seams more stable in tag v1.0.2. I can stop the server when the webb is crashed.

    I start it with this -> node loader.js --no-daemon --no-silent

    The plugin I use: https://www.nodebb.se/topic/4/bra-plugin-att-kΓ€nna-till (Something unstable here) ?
    It can trigger in 5-30 mins so ite hell to find this issue ... Gahh...

  • Swedes

    Crash when all plugins are off wen > v1.0.2
    Could be nodebb-theme-persona ??

    .... Trying master now. Maybe that works πŸ™‚

    ... Nope, master with no plugins and all disabled dont work. It could be docker or something in the DB. There must be a better way to troubleshoot this?

    Any new system dependency for > v1.0.2 ??

  • Swedes

    Need help here! I am stuck!

    If I connect to the same DB v1.0.2 works but not > v1.0.2. It dies random when you click in the menu om the site. (But you can still stop the server with nodebb stop without error) I get no errorlog what so ever! It just dies on me!

    I have another DB with less data.(Both are small databases) that seams to work with >v1.0.2. I guess its something in the DB that triggers this.

    How can I troubleshoot this?

  • Swedes

    1. I need a tip about database structure checker for nodebb (My other db is still alive so something is wrong).
    2. More verbose debugging somehow
    3. Is it possible to clean the db somehow without loosing data?

    @psychobunny what tools do you use to troubleshoot the system?


  • did u run ./nodebb upgrade??

  • Swedes

    Yes i did πŸ™‚ More good ideas?

  • Swedes

    Trying now with node debug app.js but still no output 😞 Iam am stuck with v1.0.2. Unable fix this.

  • Swedes

    Is it possible to remove every plugin-settings from the DB? Or some other type of cleanup !


  • Not having problems with the version but this topic brings up a good thing to have. A clean import/export feature built in to nodbeb would be nice. I believe wp export cleanly without all the "crap" and then imports into completely new clean install.

  • Swedes

    I will need to wait for at fix for this, I am stuck at 1.0.2 😞

  • Plugin & Theme Dev

    iΒ΄m ok with 1.0.3, did u tried fresh install?

  • Plugin & Theme Dev

    @Jenkler you can't expect a fix if the issue can't be identified.

  • Swedes

    I have troubleshooted for 4 days with no success. Dont know what todo. Clean install works. It somthing in the database that triggers this 😞 and I have no idea what todo next 😞

  • Swedes

    I am now running with v1.0.2 and updated plugins and it works. But if I try to upgrade to >v1.0.2 the frontend crashes with NO error, Just hangs. The fronted just stops taking in connections and it works to stop and restart nodebb. The crash comes after a while. 5-60 mins 😞

    Maybe som plugin setting that fucks the db up!
    Its not only one site. I have atleast 2> sitest that behaves this way.
    Tried node debug and nodebb debug, no success. Its just not f***ng working πŸ˜›


  • @Jenkler 1.0.3 seems ok to me, and if a clean install behaves ok, it seems something with the particular data or modifications of your install. That said its very rare that the process crahs without any log. Did you at least find when the crash happens in terms of front end actions you do that makes the crash happens?

    I would delete all info of plugins and custom data of BBDD and go progressively adding info to the BBDD in order to identify if it is a problem generated by the data.

  • Plugin & Theme Dev

    Looks like we got another case like this: https://community.nodebb.org/topic/8904/why-do-i-need-to-restart-my-nodebb-every-couple-of-hours

    Sadly I still can't give any further suggestions... No idea what might be wrong; As @jarey mentioned it most likely is a problem of database inconsistency. I guess only the @administrators are aware of what changes happened lately to the database.

  • GNU/Linux Admin

    @Jenkler Apologies if this was asked before, but have you tried running ./nodebb reset -p and seeing if the crashes still occur? If not, re-introduce plugins one-by-one until you find the culprit...

  • Community Rep

    I've started seeing this behavior as well on my dev environment, maybe it's related?

    Running 1.x.x branch latest as of May 20ish (1.0.3 @ a196c834d9aab4e1c27965dcca623ce12e61b4ae), mongo 3.0.7

    I'll be browsing around, and can see about 10 connections in total opened up in mongo, and then after some variable number of minutes, the application just becomes unresponsive; no error logs from node bb or anything. However, I see logs from mongo like this (note the timestamps):

    2016-05-29T21:38:52.811-0700 I ACCESS   [conn11] Successfully authenticated as principal nodebb on nodebb
    
    // then, after about 19 minutes:
    2016-05-29T21:57:19.778-0700 I NETWORK  [conn2] end connection 127.0.0.1:52223 (9 connections now open)
    2016-05-29T21:57:19.778-0700 I NETWORK  [conn7] end connection 127.0.0.1:52234 (8 connections now open)
    2016-05-29T21:57:19.779-0700 I NETWORK  [conn9] end connection 127.0.0.1:52236 (7 connections now open)
    2016-05-29T21:57:19.779-0700 I NETWORK  [conn4] end connection 127.0.0.1:52231 (6 connections now open)
    2016-05-29T21:57:19.779-0700 I NETWORK  [conn8] end connection 127.0.0.1:52235 (5 connections now open)
    2016-05-29T21:57:19.782-0700 I NETWORK  [conn6] end connection 127.0.0.1:52233 (4 connections now open)
    2016-05-29T21:57:23.474-0700 I NETWORK  [conn11] end connection 127.0.0.1:52251 (3 connections now open)
    2016-05-29T21:57:23.474-0700 I NETWORK  [conn3] end connection 127.0.0.1:52224 (3 connections now open)
    2016-05-29T21:57:23.474-0700 I NETWORK  [conn5] end connection 127.0.0.1:52232 (1 connection now open)
    2016-05-29T21:57:28.231-0700 I NETWORK  [conn10] end connection 127.0.0.1:52237 (0 connections now open)
    

    @Jenkler have you found mongo logs like this at all?

    I can't think of any plugins that I have installed that would cause this, the only thing I've been changing is the theme and the composer plugin, and some fresh npm installs... I haven't been switching the NBB branch at all.

Suggested Topics

| |