• I think the problem is that when I type in the first command:
    apt-get install git nodejs redis-server npm build-essential imagemagick

    On the page with instructions (https://github.com/designcreateplay/NodeBB), there is a "#" symbol at the start of the line whereas in my terminal, there is a "$" symbol.

    I get this error when I type in that first command:
    -bash: apt-get: command not found

    What is apt-get and how do I download it so I can run the command?

  • Subsequently, here's what happens when I run this command:
    node app --setup
    (I hit enter at each step.)

    Aarons-MacBook-Air-2:nodebb aaronclaytondunn$ node app --setup
    info: NodeBB v0.2.1 Copyright (C) 2013 DesignCreatePlay Inc.
    info: This program comes with ABSOLUTELY NO WARRANTY.
    info: This is free software, and you are welcome to redistribute it under certain conditions.
    info: NodeBB Setup Triggered via Command Line
    info: Welcome to NodeBB!
    info: This looks like a new installation, so you'll have to answer a few questions about your environment before we can proceed.
    info: Press enter to accept the default setting (shown in brackets).
    URL of this installation (http://localhost) warn: Couldn't find convert. Did you install imagemagick?
    URL of this installation (http://localhost)
    Port number of your NodeBB (4567)
    Use a port number to access NodeBB? (y)
    Please enter a NodeBB secret (cefdd292-d74d-42b8-9ad8-a0161750c96f)
    IP or Hostname to bind to (
    Which database to use (redis)
    Host IP or address of your Redis instance (
    Host port of your Redis instance (6379)
    Password of your Redis database
    Which database to use (0..n) (0)
    info: Configuration Saved OK
    info: Populating database with default configs, if not already set...
    error: undefined
    warn: NodeBB Setup Aborted.

  • NodeBB Admin

    Check out http://jason.pureconcepts.net/2011/12/installing-node-js-npm-redis-mac-os-x/.

    Some of it is outdated, looks like nodejs has a package for macosx so maybe you can just install that. Then you need to install the other packages ie redis imagemagick.

    Once all dependencies are installed node app --setup will work. The error you are getting right now is due to redis not running.

  • Thanks. I have node and I just followed the instructions on the link you sent to install redis. But I get the same error when I run "node app --setup."

    How do you get the terminal to switch from $ to #?


  • GNU/Linux Admin

    How do you get the terminal to switch from $ to #?

    # just means "do this as the root user", so in short: prepend all of the commands with sudo

  • NodeBB Admin

    Also make sure redis is running. Try redis-cli in console to see if you can get in.

  • Hmmm...can't get in. Here's what happened:

    | $ redis-cli
    | Could not connect to Redis at Connection refused
    | not connected>

    I think I just don't have Redis set up properly. I'll work on that. But now I'm wondering--should I be using Redis in the first place? I am creating a forum to host on AWS and the database needs to support svg, pdf, and png filetypes. Is Redis the right option? If not, what are my options?

    Thanks for all the help!

  • NodeBB Admin

    NodeBB doesn't store files in the database, it will store images and files locally or images on imgur if you provide a imgur clientID in admin panel. We will add s3 storage support too.

  • Do you have any suggestions for using this software to host a forum on AWS? I'm not clear on where everything would be stored...

  • NodeBB Admin

    You would just create an EC2 instance and install all dependencies and then install NodeBB. That should work fine. After that you can either add a imgur client ID so that all images are uploaded to imgur or enable local file uploads. When local file uploads are enabled all the files go to the /public folder in the NodeBB installation folder. Obviously its more preferable to have S3 support so you can store files there.

  • Thanks for the overview!

    Now I'm trying to run the project. I got redis set up. I managed to start the server the first few times I tried it, but then the next time, I got this result:

    $ redis-server
    [25313] 13 Jan 17:46:33.969 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
    [25313] 13 Jan 17:46:33.971 * Max number of open files set to 10032
    [25313] 13 Jan 17:46:33.972 # Creating Server TCP listening socket *:6379: bind: Address already in use

    Additionally, even when I got the server to run, when I did "npm install" and then "node app.js," I got an error saying bcrypt wasn't installed even though I had listed it as a dependency.

    Any ideas on how to solve these issues? Thanks!

  • Okay, I figured out how to shutdown the redis instance so ignore the top part of my last question.

    But I am still having issues with bcrypt. The readout when I do "npm install" says there's a problem with bcrypt itself and you can see what happens when I try running the code. How do I get around this?

    $ node app.js
    info: NodeBB v0.2.1 Copyright (C) 2013 DesignCreatePlay Inc.
    info: This program comes with ABSOLUTELY NO WARRANTY.
    info: This is free software, and you are welcome to redistribute it under certain conditions.
    info: Initializing NodeBB v0.2.1, on port 4567, using redis store at
    info: NodeBB instance bound to: Any address (
    warn: Couldn't find convert. Did you install imagemagick?

    throw err;
    Error: Cannot find module 'bcrypt'
    at Function.Module._resolveFilename (module.js:331:15)
    at Function.Module._load (module.js:273:25)
    at Module.require (module.js:357:17)
    at require (module.js:373:17)
    at Object.<anonymous> (/Users/aaronclaytondunn/Documents/WebDev/nodebb/nodebb1/nodebb/src/user.js:1:76)
    at Module._compile (module.js:449:26)
    at Object.Module._extensions..js (module.js:467:10)
    at Module.load (module.js:349:32)
    at Function.Module._load (module.js:305:12)
    at Module.require (module.js:357:17)

  • GNU/Linux Admin

    CentOS users have also reported problems installing bcrypt.

    Try installing this instead, and let us know if it works?


  • Thank you, that worked.

Suggested Topics

| | |

© 2014 – 2022 NodeBB, Inc. — Made in Canada.