[sockbot] I wanted a robot, So I made one

  • Plugin & Theme Dev

    @TheWorms
    Assuming you're absolutely 100% certain the login credentials are correct in the configuration file, the only two things that come to mind are:

    • Check the username. It is case sensitive for logging in via the bot. I keep meaning to fix that but........ yeah havent gotten around to it yet.
    • Check the forum key. are you sure you've set it correctly. If you havent set it it will default to https://what.thedailywtf.com which is almost certainly not what you want.

  • @accalia

    sockbot config.yml
    [2017-10-09T17:54:15.156Z] Starting Sockbot 6.3.6
    [2017-10-09T17:54:15.165Z] Loaded configuration file: config.yml
    [2017-10-09T17:54:15.165Z] Activating logon: LdM
    [2017-10-09T17:54:15.357Z] Using provider nodebb for LdM
    [2017-10-09T17:54:15.361Z] Loading plugin echo for LdM
    [2017-10-09T17:54:15.362Z] LdM ready for login
    [2017-10-09T17:54:15.404Z] A-derp! Fatal Startup Error: connect ECONNREFUSED 1xx.1xx.1xx.2xx:443

    DEBUG=* sockbot config.yml
    [2017-10-09T18:04:37.268Z] Starting Sockbot 6.3.6
    [2017-10-09T18:04:37.277Z] Loaded configuration file: config.yml
    [2017-10-09T18:04:37.278Z] Activating logon: LdM
    sockbot requiring providers nodebb as /usr/lib/node_modules/sockbot/lib/../providers/nodebb +0ms
    [2017-10-09T18:04:37.469Z] Using provider nodebb for LdM
    [2017-10-09T18:04:37.473Z] Loading plugin echo for LdM
    sockbot requiring plugins echo as /usr/lib/node_modules/sockbot/lib/../plugins/echo +195ms
    [2017-10-09T18:04:37.474Z] LdM ready for login
    sockbot:provider:nodebb begin configuration fetch for CSRF token +0ms
    sockbot:provider:nodebb failed configuration fetch for CSRF token +38ms
    sockbot Error: connect ECONNREFUSED 192.168.1.2:443
    sockbot at Object._errnoException (util.js:1019:11)
    sockbot at _exceptionWithHostPort (util.js:1041:20)
    sockbot at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1175:14) +40ms
    [2017-10-09T18:04:37.513Z] A-derp! Fatal Startup Error: connect ECONNREFUSED 1xx.1xx.1xx.2xx:443

  • Plugin & Theme Dev

    huh. connection refused, that's a new one, and not something I can help with. You'll have to contact the one running the forum you're connecting to and find out from them why your bot is being refused connection.

    Sorry, but that error really isn't something i can sort out on my end. it's on the server side.


  • oki tks

    i'm use nginx proxy and host forum & sockbot in same webserver 😉

Suggested Topics

| |