v1.0.2: Lavender Theme: ACP says it is 3.0.9 but it is not

Solved Technical Support
  • My PRD is still v0.9.4. Testing the upgrade to v1.0.2 in my DEV (I made a new good copy of my PRD v0.9.4 to DEV) gives me a problem with the Lavender theme. Specifically the post time is not displaying. I scratch my head because I already had this problem when I tested an upgrade to v1.0.0. See here for that thread.

    In my v1.0.2 DEV ACP I see that Lavender is the most recent version, 3.0.9

    Further curious I check github for this fix as it was discussed previously (see the thread linked above). https://github.com/NodeBB/nodebb-theme-lavender/pull/67/commits/b60203621d37e17297c31e30e9fa9264a9b855bf

    I compare what github shows in green with what the file looks like on my disk and they do not match! This is what is on my disk:

    $ cat node_modules/nodebb-theme-lavender/templates/partials/topic/post-editor.tpl
    <span component="post/editor" class="<!-- IF !editor.username --> hidden<!-- ENDIF !editor.username -->">, [[global:last_edited_by, {editor.username}]] <span class="timeago" title="{relativeEditTime}"></span></span>

    Clearly you can see that the file on disk still has the old bits regarding title="{relativeEditTime} as opposed to what is on github title="{editedISO}

    Now for the million dollar question.

    How does my v1.0.2 which says I have nodebb-theme-lavender version 3.0.9 still have the old file from v0.9.4? But more importantly how do I get the correct version, 3.0.9, of Lavender?

    Thank you.

  • @rod check the github commits for lavender. the pull request you are pointing to is merger after 3.0.9 is published. A new version of the theme is not published after the specified pull request is merged.

    ACP is correctly showing the theme version.

    Anyway you are better off without that pull request as it will not work. The pull request you want is this one... https://github.com/NodeBB/nodebb-theme-lavender/commit/9508194714e623d45adc879a540dc18b3cfd7e95

  • @pichalite Thank you for the information. I manually edited that file, topic.tpl, but it hasn't solved my problem. Still no time at all shown. 😞

    v1.0.2 Lavender theme 3.0.9

    v0.9.4 Lavender theme 3.0.2

    Also you'll notice that v0.9.4 / 3.0.2 has the nice fade out that v1.0.2 / 3.0.9 does not have.

  • @pichalite Oh poo-poo. I see that the time "features" were taken out after 3.0.2. 😞


    I can deal with that but what about the image fade out. I liked that for long posts on my category listing.

  • @rod said:

    I manually edited that file, topic.tpl, but it hasn't solved my problem. Still no time at all shown.

    The file you edited is not the file for the categories page. That's a different location.

    I see that the time "features" were taken out after 3.0.2.

    Time features are not removed, they were just slightly modified to fix an issue.

    I am sending a PR to fix a couple of timestamp issues. Make those changes and you will see the timestamps.

  • @pichalite That fixed the time display issue! Thank you.

    Now, how about the fade out? Is that gone from the theme?

  • @rod fade out works fine for me on a fresh install with latest lavender.


  • @pichalite Ugh. 😞 I didn't do anything to the theme that should make that stop working. When I copy my PRD to DEV it still works but immediately after the v1.0.2 (and previously v1.0.0) upgrade it stops.

  • @pichalite Ohh, I did futz with the vanilla theme a little to get the ns-likes plugin working as I wanted it. Maybe that's causing the problem. I'll look at that later.

  • @pichalite This is very odd.

    • When I visit my dev forum from my iPhone (Safari) I see the correct fade out on long posts.
    • When I visit my dev forum from my home Mac (using Safari) I also see the correct fade out.
    • When I visit my dev forum from my office Windows PC (using Firefox) I do not see the correct fade out.
    • Now for the odditity. If I visit my production forum from my same office Windows PC (using Firefox) I do see the correct fade out.


    Tips or clues on what to look at or caches to clear, etc?

    Thank you.

Suggested Topics