Does NodeBB support Nodejs 4.2.1?

  • Plugin & Theme Dev

    @royburns yes

  • @pichalite

    after installed, i run "curl http://localhost:4567'
    but there were some error occur, below:

    6/3 04:37 [16853] - info: NodeBB Ready
    6/3 04:37 [16853] - info: Enabling 'trust proxy'
    6/3 04:37 [16853] - info: NodeBB is now listening on:
    MongoError: topology was destroyed
    at Server.update (/opt/nodebb_outofchina/node_modules/mongodb/node_modules/mongodb-core/lib/topologies/server.js:1083:49)
    at Server.update (/opt/nodebb_outofchina/node_modules/mongodb/lib/server.js:338:17)
    at updateDocuments (/opt/nodebb_outofchina/node_modules/mongodb/lib/collection.js:999:19)
    at Collection.update (/opt/nodebb_outofchina/node_modules/mongodb/lib/collection.js:1037:44)
    at tryCatcher (/opt/nodebb_outofchina/node_modules/connect-mongo/node_modules/bluebird/js/release/util.js:16:23)
    at ret [as updateAsync] (eval at <anonymous> (/opt/nodebb_outofchina/node_modules/connect-mongo/node_modules/bluebird/js/release/promisify.js:184:12), <anonymous>:13:39)
    at MongoStore.<anonymous> (/opt/nodebb_outofchina/node_modules/connect-mongo/src-es5/index.js:281:39)
    at MongoStore.tryCatcher (/opt/nodebb_outofchina/node_modules/connect-mongo/node_modules/bluebird/js/release/util.js:16:23)
    at Promise._settlePromiseFromHandler (/opt/nodebb_outofchina/node_modules/connect-mongo/node_modules/bluebird/js/release/promise.js:503:31)
    at Promise._settlePromise (/opt/nodebb_outofchina/node_modules/connect-mongo/node_modules/bluebird/js/release/promise.js:560:18)
    at Promise._settlePromiseCtx (/opt/nodebb_outofchina/node_modules/connect-mongo/node_modules/bluebird/js/release/promise.js:597:10)
    at Async._drainQueue (/opt/nodebb_outofchina/node_modules/connect-mongo/node_modules/bluebird/js/release/async.js:131:12)
    at Async._drainQueues (/opt/nodebb_outofchina/node_modules/connect-mongo/node_modules/bluebird/js/release/async.js:136:10)
    at Immediate.Async.drainQueues [as _onImmediate] (/opt/nodebb_outofchina/node_modules/connect-mongo/node_modules/bluebird/js/release/async.js:16:14)
    at processImmediate [as _immediateCallback] (timers.js:383:17)

  • Plugin & Theme Dev

    @royburns check to make sure your mongo db is running.

    what's your mongo db version?

  • @pichalite yep, the mongo is of course running.
    the version is v3.2.3

  • Plugin & Theme Dev

    @royburns is NodeBB running without errors?

  • @royburns said:
    the log after install, it looks success:

    6/3 04:37 [16853] - info: NodeBB Ready
    6/3 04:37 [16853] - info: Enabling 'trust proxy'
    6/3 04:37 [16853] - info: NodeBB is now listening on:

  • @pichalite

    the log after install, it looks success except two warns, below is the full log:

    [[email protected] nodebb_outofchina]# ./nodebb log

    Type Ctrl-C to exit

    6/3 05:48 [17353] - warn: You have no mongo password setup!
    6/3 05:48 [17353] - info: [database] Checking database indices.
    6/3 05:48 [17353] - warn: [] Clustering detected, you are advised to configure Redis as a websocket store.

    6/3 05:48 [17353] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run ./nodebb reset -p PLUGINNAME to disable it.

    • nodebb-theme-persona

    6/3 05:48 [17353] - info: NodeBB Ready
    6/3 05:48 [17353] - info: Enabling 'trust proxy'
    6/3 05:48 [17353] - info: NodeBB is now listening on:

  • Plugin & Theme Dev

    @royburns try accessing it using the ip address of the machine


  • @pichalite
    it's also the same error 😞 :

    Cannot GET /

  • @pichalite
    it's ok now, i reinstall the nodejs and run "npm install node-gyp -g" to install graceful-js etc.

  • im also having this problem, it seems to only happen when the imgur plugin is active. Disabling it allows nodebb to start and work just fine

  • From my experience 90% of Cannot GET / errors is when it can't connect to mongo db.

    Try to sudo service mongod restart

  • Running 5.9.1 on a test setup, no problems.

  • @tkiblin Does your environment include imgur plugin?

Suggested Topics

| | |

© 2014 – 2022 NodeBB, Inc. — Made in Canada.