[Solved] Spinning up a second instance of NodeBB on same server.. issues with redis?


  • That did the trick, thanks! if you couldnt tell, I already love the product and am deploying in two new projects.


  • Hi,

    I'm also trying to run a second NodeBB instance (love this new generation forum 🙂 ) on same server.
    I'm encountering difficulties, but not the same.

    I run the setup, defined a different port 4568 and different Redis DB number 1 (first instance on 4567 with RDS DB 0).

    Starting up this second NodeBB instance I see in the log that the startup doesn't end and restart just after attempting to listen on my 192.168.1.10:4568, endlessly.

    info: [user.startJobs] Registering User Jobs
    info: [meta/css] Minifying LESS/CSS
    info: [sounds] Sounds OK
    info: [themes] Compiling templates
    info: [themes] Successfully compiled templates.
    info: NodeBB attempting to listen on: 192.168.1.10:4568
    info: NodeBB v0.4.3 Copyright (C) 2013-2014 NodeBB Inc.
    info: This program comes with ABSOLUTELY NO WARRANTY.
    info: This is free software, and you are welcome to redistribute it under certain conditions.

    Any idea about what I miss ?

    Regards
    info:
    info: Time: Tue Jun 10 2014 22:25:17 GMT+0200 (CEST)


  • @Frédéric-Coubard Can you try ./nodebb dev on your second instance and paste the result.

  • GNU/Linux Admin

    @Frédéric-Coubard Looks like there is no problem to me?


  • @a_5mith will try this evening.


  • @julian you mean it is normal this instance restarting endlessly ?

  • GNU/Linux Admin

    @Frédéric-Coubard Ah, missed that it was restarting over and over again. Yeah, run it in dev mode and let's see what the error is...


  • Sorry for this late feedback.
    For some reasons I had to reinstall my whole server. And now the run of the two nodeBB instances is working fine. So maybe nothing related to nodeBB itself. That rocks :-). Thanks for your answers.

  • Plugin & Theme Dev

    I'm having an issue where I've installed two instances of NodeBB on the same server, set the redis databases to be different yet the following error occurs:

    Whenver you login or logout of one forum, you logout of the other. Is this a common issue and can be solved easily or am I in deep water here?

  • GNU/Linux Admin

    1. I find it hilarious that only as little as 6 months ago, our totally legitimate advice was "try dropping your db and reinstall"
    2. Are the secrets in config.json different?
    3. Are the two NodeBBs on the same base_url?
    4. Check the cookie saved in the browser, I'm thinking perhaps they're overwriting each other...
  • Plugin & Theme Dev

    @julian

    1. That's hilarious 😛

    2. The secrets are indeed different

    3. The base_url's are the same except for the ports

    4. I'll clear my cookies and see if that fixes the issue.

  • GNU/Linux Admin

    As far as I know, the ports aren't considered in a cookie's domain path (limitation of the cookie mechanism, I think), so that would explain it. They're overwriting each other.

  • Plugin & Theme Dev

    It seems that even if I refresh on one instance it logs me out of the other. How strange.


Suggested Topics

| |