[nodebb-plugin-blog-comments] Blog Commenting Engine (Ghost, Wordpress widget)

  • Global Moderator Plugin & Theme Dev

    @c3do it's just a warning. You can ignore it. Are you having any actual issues with the functionality of the plugin?

  • @PitaJ yesterday, i could not go on the settings page. i saw this warning, so i thought it was the problem.
    I had run the command "./nodebb build" but the warning was always here. So, I was obsessed with the warning.
    Finally, the command had solved the problem without me realizing it. I can access the settings page despite the warning.

  • I am on ghost. I can create the new topic and comment from ghost. But, last comments does not appear in ghost post.

  • I installed the plugin, setup comments.php on Wordpress and I see the following on Wordpress:

    "Commenting has been disabled" with the "Publish this article to NodeBB"


    However, when I push the button, I get this error:

    Internal Error.
    Oops! Looks like something went wrong!
    Unexpected end of JSON input


    Could this be a problem with my forum being installed in a subdir?

    cc: @psychobunny @baris

  • I'm also seeing this in the logs:

    2019-02-07T22:14:16.880Z [4567/23701] - warn: [nodebb-plugin-blog-comments] Origin (undefined) does not match hostUrls: https://www.axisandallies.org
    2019-02-07T22:14:42.601Z [4567/23701] - error: /forums/comments/publish
    SyntaxError: Unexpected end of JSON input
        at JSON.parse (<anonymous>)
        at Comments.publishArticle (/var/srv/nodebb/node_modules/nodebb-plugin-blog-comments/library.js:135:15)
        at Layer.handle [as handle_request] (/var/srv/nodebb/node_modules/express/lib/router/layer.js:95:5)
        at next (/var/srv/nodebb/node_modules/express/lib/router/route.js:137:13)
        at Route.dispatch (/var/srv/nodebb/node_modules/express/lib/router/route.js:112:3)
        at Layer.handle [as handle_request] (/var/srv/nodebb/node_modules/express/lib/router/layer.js:95:5)
        at /var/srv/nodebb/node_modules/express/lib/router/index.js:281:22
        at Function.process_params (/var/srv/nodebb/node_modules/express/lib/router/index.js:335:12)
        at next (/var/srv/nodebb/node_modules/express/lib/router/index.js:275:10)
        at rewrite (/var/srv/nodebb/src/controllers/home.js:33:10)

    It's odd that Origin is undefined, right?

    Also, here's the forum data being posted, it's not JSON and it's missing a bunch of stuff.


    Oddly I get the same error with and without the JSON API wordpress plugin activated. (It is currently activated)

  • This post is deleted!

  • Okay, the solution to this is that the comment in the Wordpress php that the categoryID is options is not correct. You need the category ID.

    But there are still some subdir issues happening for me.

  • Does the plugin not show the comments from the nodebb post?

  • Admin

    @djensen47 will look into this Monday, are you on latest WP /JSON API (though I think the latter hasn't been updated in a while)?

    Dear PHP, I thought I didn't have to deal with you anymore πŸ˜„

  • @psychobunny I filed some bugs and included a PR for one of the bugs.

  • This post is deleted!

  • @psychobunny

    2019-12-23T13:37:40.855Z [undefined/13516] - error: [build] Encountered error during build stepEACCES: permission denied, rmdir '/var/www/nodebb/build/public/plugins/nodebb-plugin-blog-comments' {"errno":-13,"code":"EACCES","syscall":"rmdir","path":"/var/www/nodebb/build/public/plugins/nodebb-plugin-blog-comments","stack":"Error: EACCES: permission denied, rmdir '/var/www/nodebb/build/public/plugins/nodebb-plugin-blog-comments'"} 2019-12-23T13:37:40.856Z [undefined/13516] - error: EACCES: permission denied, rmdir '/var/www/nodebb/build/public/plugins/nodebb-plugin-blog-comments' {"errno":-13,"code":"EACCES","syscall":"rmdir","path":"/var/www/nodebb/build/public/plugins/nodebb-plugin-blog-comments"} [email protected]:/var/www/nodebb$

    When I run the ./nodebb build command, I get the above life. Which command should I run to completely remove this plugin?

  • ./nodebb reset -p <plugin name>

  • @psychobunny Does this plug-in work with Ghost 3.0?

    The nodebb project uses ghost for its own blog, and comments are working, but I don’t know which version of ghost you are running.

    I have a ghost website, but have not installed nodebb yet.

  • GNU/Linux Admin

    @nibl hello there! We're actually running ghost 2.something, so I can't guarantee it'll work with Ghost 3.

    We're probably going to upgrade Ghost at some point, and the blog comments plugin will be upgraded with it.

  • Thanks @julian. I will try nodebb comments with ghost 3.0. If it doesn't work, will the dev team be able to give me some hints on patching it? Or would I have to wait until whenever the plug-in is officially fixed?

  • Is there a roadmap for when the plugin will support ghost 3.0?
    Unfortunately it doesn't work with Ghost 3.0 at the moment.

  • @psychobunny said in [nodebb-plugin-blog-comments] Blog Commenting Engine (Ghost, Wordpress widget):

    Wordpress JSON API plugin

    this plugin is deprecated is there any other solution ?

  • @julian @psychobunny is there any update on this for WordPress as it's broken right now on WordPress because the Wordpress JSON API plugin is deprecated and not available to download anymore

  • i think you should consider using the built-in WordPress REST API to avoid such problems in the future

Suggested Topics

| |