Error While Upgrading v0.9.4 to v1.0.0: ERR value is not a valid float

Solved Technical Support
  • I ran into trouble upgrading my dev forum from v0.9.4 to v1.0.0. Specifically:

    $ ./nodebb upgrade
    1. Bringing base dependencies up to date... OK
    2. Updating NodeBB data store schema.
    3/3 14:25 [4439] - info: Beginning database schema update
    3/3 14:25 [4439] - info: [2015/09/30] Converting default Gravatar image to default User Avatar skipped
    3/3 14:25 [4439] - info: [2015/11/06] Gravatar removal skipped
    3/3 14:25 [4439] - info: [2015/12/15] Upgrading chats
    3/3 14:25 [4439] - info: adding message 1 to new roomID 3
    3/3 14:25 [4439] - info: adding message 2 to existing roomID 4
    3/3 14:25 [4439] - info: adding message 3 to existing roomID 4
    3/3 14:25 [4439] - info: adding message 4 to new roomID 4
    3/3 14:25 [4439] - info: adding message 5 to new roomID 5
    3/3 14:25 [4439] - error: [upgrade] Errors were encountered while updating the NodeBB schema: ERR value is not a valid float
                                NodeBB Upgrade Complete!

    This is:

    $ git rev-parse --abrev-ref HEAD

    Which is odd because I think v1.0.0 is fb4f1e1315bed7b425756ad25a396c42b2ba3891

    I got here by doing these steps:

    $ ./nodebb stop
    Stopping NodeBB. Goodbye!
    $ git rev-parse --abrev-ref HEAD --abrev-ref
    $ git fetch
    remote: Counting objects: 741, done.
    remote: Compressing objects: 100% (740/740), done.
    remote: Total 741 (delta 330), reused 1 (delta 0), pack-reused 0
    Receiving objects: 100% (741/741), 549.67 KiB | 0 bytes/s, done.
    Resolving deltas: 100% (330/330), done.
       44aae7d..3f28729  fix-vendors -> origin/fix-vendors
       5f7cc00..3abe19f  master     -> origin/master
     * [new branch]      v1.x.x     -> origin/v1.x.x
     * [new tag]         v1.0.0     -> v1.0.0
    $ git checkout v1.x.x
    Branch v1.x.x set up to track remote branch v1.x.x from origin.
    Switched to a new branch 'v1.x.x'
    $ git merge origin/v1.x.x
    Already up-to-date.
    $ git rev-parse --abrev-ref HEAD

    Any helpful thoughts on what to check or do next?

    Thank you.

  • @rod said:

    Which is odd because I think v1.0.0 is fb4f1e1315bed7b425756ad25a396c42b2ba3891

    that's the hash for the initial release of v1.0.0

    there were some updates to the branch after that to update compatibility for default plugins so the hash 0b35c81586d85bb916e9336daf52694f51b182c9 is the latest v1.x.x stable release

  • @pichalite I was hoping it was going to be something obvious. 馃槮

  • @rod the hashes don't have anything to do with your upgrade issue. looks like the upgrade script ran into an issue when converting existing chats to the new group chat feature

  • @pichalite Oh good! Next question, is it possible to delete the chats from redis via redis-cli?

  • @rod you should be able to delete them... unfortunately I am not too familiar with redis commands so you will have to wait for someone with redis knowledge to reply

  • If you're desperate, you can always connect using Redis Desktop and blast them away within the GUI. Sorry, I'm afraid I don't know the CLI commands to assist.

  • @ThingBreaker do you mean Redis Desktop?

  • @pichalite, you didn't see anything 馃槈

  • Is it safe to upgrade to 1.0.0 from 0.9.4 now ?

  • @Jenkler In my case, no not yet. There appears to be an issue with the chats in my forum. I am going to delete them from the database (sorry users) and attempt the upgrade again.

    When I finally do this upgrade to production I will send a mass email to my users letting them know that their chat threads will be deleted and give them a little time to make a copy of them if they care about retaining the content.

  • Ok, good to know

    "I am going to delete them from the database" <-- Can you do that from NodeBB ACP ?

  • @Jenkler Unfortunately I cannot.

    I am using redis and the only plugin I found that manages database entries is for Mongodb. I am going to attempt to load the RedditRedis Desktop Manager. @ThingBreaker

  • @pichalite I've made access to my redis database. I see the "messages" that I should delete. Question about that. Should I delete the entire "message:1", "message:2", etc., entries?

    Also, it looks like my first attempt to upgrade created four chat rooms. Should I delete them as well or leave them?

    Thank you.

  • @rod not sure. you can probably delete them if you don't need those back

  • After deleting the "message:x" database keys the upgrade completed without error.

    Upon startup though I am getting an error that is keeping NodeBB from starting:

    $ ./nodebb log
    Type Ctrl-C to exit
    NodeBB v1.0.0 Copyright (C) 2013-2014 NodeBB Inc.
    This program comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to redistribute it under certain conditions.
    For the full license, please visit:
    Clustering enabled: Spinning up 1 process(es).
    4/3 14:13 [17972] - info: Time: Fri Mar 04 2016 14:13:43 GMT-0700 (MST)
    4/3 14:13 [17972] - info: Initializing NodeBB v1.0.0
    [outdated] nodebb-plugin-soundpack-default installed v0.1.5, package.json requires 0.1.6
    4/3 14:13 [17972] - warn: One or more of NodeBB's dependent packages are out-of-date. Please run the following command to update them:
    4/3 14:13 [17972] - warn:     ./nodebb upgrade
    [cluster] Child Process (17972) has exited (code: 0, signal: null)

    I ran the upgrade again but still end up with this error upon starting. I do not recall installing the nodebb-plugin-soundpack-default plugin. I believe it is native to NodeBB.

    Help please on what to look at next.

    Thank you.

  • @rod that's an issue reported here

    pull latest v1.x.x and try upgrade again

  • @pichalite I did a git pull and now have a hash of 55b43dca23702dca935aabb953594c8a343ee259

    Ran the upgrade successfully.

    Started NodeBB but had an imgbed plugin errror. I ran the ./nodebb reset -p nodebb-plugin-imgbed command and then attempted the startup. NodeBB started up this time!

    I have upgraded all of my plugins that had available upgrades including the imgbed one. Now on startup it doesn't throw an error. Overall everything is working and I will mark this thread as solved. I won't be upgrading my production to v1.0.0 yet as the Amazon S3 plugin caused NodeBB to crash. I will wait to see if that plugin ever gets updated. @wladiston

    Thank you for your help.

  • Followup. I found a different Amazon S3 uploader plugin that seems to be working under v1.0.0. If interested see here

Suggested Topics

  • Values to add to email templates

    Unsolved Technical Support
    0 Votes
    2 Posts

    @mattdjuk You can do a search for the string emailer.send( in src/ to see every invocation of the emailer.

    From the first argument passed in, you can see which template it attempts to use, and the third argument shows the template data passed in.


    await emailer.send('notification', uid, { path: notification.path, notification_url: notification.path.startsWith('http') ? notification.path : nconf.get('url') + notification.path, subject: utils.stripHTMLTags(notification.subject || '[[notifications:new_notification]]'), intro: utils.stripHTMLTags(notification.bodyShort), body: body, notification: notification, showUnsubscribe: true, })
  • 0 Votes
    7 Posts

    @PitaJ Thanks. I was seeing the same "Error: Cannot find module '@babel/runtime/core-js/object/create'" issue and deleting my node_modules directory and then running

    npm install ./nodebb setup

    solved the problem for me.

  • 0 Votes
    15 Posts

    Thank you @PitaJ and @julian for your support! Everything works fine now.

    The error was because of a wrong security option in the settings and the speed of sendmail increased by itself. Probably there was a problem on the shared server during my first test.

    Keep up the great work! 馃檱 NodeBB is really great!

  • 0 Votes
    18 Posts

    @pitaj yes, I tried ./nodebb build several times, but I always used ./nodebb dev to start.

    I tried it once more as you said. ./nodebb start aborted with the message to run ./nodebb upgrade. After the upgrade and another ./nodebb start I can post and answer again! 馃槃

    I don't know why an how, but it works again. hopefully not only for a short time. 馃槈

    Thanks for you help!

  • 0 Votes
    30 Posts