WebSocket error in console..

Technical Support

Suggested Topics

  • 0 Votes
    3 Posts

    A good starting point would be to disable all third-party plugins and see if that resolves the issue.

  • 0 Votes
    2 Posts

    @h7 tried on a different Debian 7 (Wheezy) server, to make sure this is a common issue:

    Node.js v4.2.2 Redis server v=3.2.11 NodeBB v1.0.3

    NodeBB installs again, without errors but the log comes back with the exact same [2458] - error: undefined

    npm rm nodebb-plugin-emoji-one npm install [email protected]

    fixed that error, now:

    info: Time: Sun Oct 08 2017 04:59:32 GMT+0300 (MSK) info: Initializing NodeBB v1.0.3 [outdated] nodebb-plugin-emoji-one installed v1.1.4, package.json requires 1.1.0 warn: One or more of NodeBB's dependent packages are out-of-date. Please run the following command to update them: warn: ./nodebb upgrade [cluster] Child Process (6503) has exited (code: 0, signal: null)

    OK, removing the plugin npm rm nodebb-plugin-emoji-one and ./nodebb start worked, NodeBB v1.0.3 running, still can't log-in:

    warn: [meta/dependencies] Bundled plugin nodebb-plugin-emoji-one not found, skipping dependency check. [minifier] file not found, node_modules/socket.io-client/socket.io.js [minifier] file not found, node_modules/socket.io-client/socket.io.js info: NodeBB Ready info: Enabling 'trust proxy' info: NodeBB is now listening on: error: /login invalid csrf token error: /login invalid csrf token

    using older versions of socket.io:

    npm remove socket.io npm remove socket.io-client npm install [email protected] npm install [email protected]

    did the trick, NodeBB v1.0.3 running and ready for myBB to NodeBB transition

  • 0 Votes
    1 Posts

    I'm trying to install NodeBB using the CentOS documentation for install and am admittedly a noob. Things seem to go well until I get to installing the Development Tools in step 3 (https://nodebb.readthedocs.io/en/latest/installing/os/centos.html).

    I get an error that says Error: Package: intltool-0.41.0-1.1.e16.noarch (base) Requires: perl(XML::Parser).

    However, I'm pretty positive I have the 2.44 version of the Perl XML Parser installed. And, my Perl version is v5.10.1 - any help would be amazing.

    Thanks in advance!


  • Application Error

    Technical Support
    0 Votes
    2 Posts

    Can you run it in a one-off dyno to see what the error is? Perhaps inspect the log? The heroku log doesn't show much for debuging 😦

  • 0 Votes
    3 Posts

    Hi Dan! As advised via chat, can you log in successfully onto this forum via Safari?