[nodebb-theme-pewter] Pewter Theme

  • Admin

    Oh - that explains a lot. Good catch, lol


  • I get 2 issues so far in this delicious looking theme.

    1. Same as the others the top right login box does not change when logged in. Happens on both Chrome and Safari for me, caches cleared and all that jizz.

    2. Clicking login or register just doesn't work in Safari at all for me. Logged in or not.


  • @Steve said:

    I get 2 issues so far in this delicious looking theme.

    1. Same as the others the top right login box does not change when logged in. Happens on both Chrome and Safari for me, caches cleared and all that jizz.

    2. Clicking login or register just doesn't work in Safari at all for me. Logged in or not.

    Scratch #2, I just realized it's not working because I'm logged in. I log out it works when clicked.

    So when it stays with Anon top-right corner it renders those buttons useless since I guess they shouldn't be there anyhooters.

  • Admin

    Weird. Do you reproduce this issue on my demo forum?


  • @psychobunny said:

    Weird. Do you reproduce this issue on my demo forum?

    Yes. Both in Safari and Chrome. I made account, logged in, top right remains anon.


  • Another thing I'd like to see. I can probably add it myself but I think 99% would want it.

    SSO / Alternative Reg section added to the login/register pages.

  • Plugin & Theme Dev Anime Lovers GNU/Linux

    @psychobunny said:

    thanks guys 🙂 hope to inspire a whole onslaught of new themes!

    Definitely. 👍


  • Here's another for ya.

    In Chrome online (Safari is fine) when clicking the HOME breadcrumb this is what it ends up looking like every time.

    pewter_oops.jpg

  • Admin

    Haha wow, that's totally fubared. Wonder if your vanilla theme / NodeBB is up to date? I just installed this theme for one of our members @ http://365players.nodebb.com/ and didn't have any issues (seemingly).


  • @psychobunny said:

    Haha wow, that's totally fubared. Wonder if your vanilla theme / NodeBB is up to date? I just installed this theme for one of our members @ http://365players.nodebb.com/ and didn't have any issues (seemingly).

    it was a fresh install a day ago

  • Admin

    Try this, switch to the vanilla theme and then switch back to this theme (and reboot NodeBB). It seems like you have half of lavender (home.tpl) but the rest is Pewter (style.less). Am totally lost as to why that happened though


  • @psychobunny said:

    Try this, switch to the vanilla theme and then switch back to this theme (and reboot NodeBB). It seems like you have half of lavender (home.tpl) but the rest is Pewter (style.less). Am totally lost as to why that happened though

    Still happens.

    I'm more curious in some ways about the Anon sticking top-right on all browsers. It makes it hard for a new user to figure out how or where to change their profile details.


  • BTW when I do a page refresh (F5) it then shows just fine. Clicking any link to a "home" page, including using a widget with the domain home, ends up sending me to the wonky looking screen.


  • Also not sure if this is theme related or a site issue.

    {topics.teaser.username} does not always display an image on the thread list inside of a category.

    Keeping ya busy bro!! 🙂


  • I'll just keep piling the ideas on while I'm screwing around with this and the lavender themes trying to decide which I want to use as a base.

    on the iPad this goes into mobile mode. Problem I have is two fold.

    1 - it's in mobile mode, iPad at least sideways at minimum I'd want to see the site regular
    2 - It stretches those icons wide and narrows them, making them look like ass. Must be a cleaner way, or revert to the colors when mobile.

    Just more ideas to screw with ya @psychobunny 🙂


  • This post is deleted!
  • Admin

    Man I really need to have a look at this theme properly. I don't have an iPad/tablet though, but clearly, from above I have some bigger fish to fry. Trying to repro your bug on the homepage, I can't get that on a clean install.


  • @psychobunny said:

    Man I really need to have a look at this theme properly. I don't have an iPad/tablet though, but clearly, from above I have some bigger fish to fry. Trying to repro your bug on the homepage, I can't get that on a clean install.

    I'm on Chrome MAC in case that makes any difference.

    I think with the iPad issue it's just that the theme is triggering too early. Even though the pixel width might be X on an iPad, a website will still look good and usable. For instance, I have Lavender theme on now at supernerdz.com and it looks great on iPad, just like on my desktop. Then on phone it is the mobile version.

  • Admin

    Tomorrow morning I'll try installing this on a totally fresh install and report back to you


  • @psychobunny said:

    Tomorrow morning I'll try installing this on a totally fresh install and report back to you

    Checking in on your report sir 🙂 Don't blame ya if you didn't get to it I vanished for a week of work, court, and family medical drama lol.

    Just tried it after .4.3 update and still the top right stays at the anon / as if i didn't log in state.


Suggested Topics

| |