Noginx related Facebook authorization issue, someone halp?

  • So this is an issue i just decided to forget about, because i can't figure out how to solve it. my website , won't work with the facebook login and i think it's because of noginx. If I fill out the tables on the facebook dev app, and use my .com URL as the domain and website address, it won't work. But if I use the ip address it'll work, for me at least (others it still wont work for) and it'll create a bunch of other problems as well. So I dunno how to fix this. Maybe someone else has had similar problems? I had another noginx thread about how to install noginx, but that one went on long enough, so i figured i should start a new one.

  • GNU/Linux Admin

    Daaaayum, that's a nice lookin' forum. I love what people are doing with category images these days. Truly inspiring.

    As for your facebook login...

    • Ensure that "" is added as an app domain.
    • Your site url should probably be
    • Ensure the app ID and secret is specified correctly in the ACP, and that you restarted your NodeBB after saving those values

  • @julian thanks. I'm always tweaking things, trying to get used to editing.

    i'm pretty bad at trying to explain things to developers. So this is what i had.

    Screen Shot 2014-02-07 at 9.26.00 PM.png
    And when i click on the facebook icon on either 'register' or 'login' i recieve this message:

    Screen Shot 2014-02-07 at 9.27.33 PM.png

    Now if I change the site url to my ip address it will work, but it will take me to the Ip url, which had a ton of weird affects. Those logged into the Ip url show as offline on the domain and vice versa. Those threads which are read, will appear as unread on the ip.

  • GNU/Linux Admin

    Hm... did you turn these two options on?


    Edit: I haven't the foggiest idea what "Client Token" is...

  • I hadn't toggled "Embedded browser OAuth Login"

    After doing so i now get this message:

    Screen Shot 2014-02-07 at 9.36.28 PM.png

  • And if i look at the URL for that error page , it looks to be pinging the Ip address instead of the domain: %2Fauth%2Ffacebook.....

  • GNU/Linux Admin

    Perhaps your config.json may have its base_url set to an IP?

  • @julian it was

    "base_url": "",
    "port": "4567",

    changed it to

     "base_url": ",

    and the website goes all Error 502 on me.

  • GNU/Linux Admin

    Don't forget the ending quote on the base_url line πŸ™‚

  • @julian fixed. Still doesnt want to work.

  • GNU/Linux Admin

    What error shows up in your console when you attempt to use the proper base_url?

  • @julian said:

    What error shows up in your console when you attempt to use the proper base_url?

    [email protected]:~/mynodebb# node app
    info: NodeBB v0.3.1 Copyright (C) 2013 DesignCreatePlay Inc.
    info: This program comes with ABSOLUTELY NO WARRANTY.
    info: This is free software, and you are welcome to redistribute it under certain conditions.

    throw new Error("Error parsing your JSON configuration file: [" + self.f
    Error: Error parsing your JSON configuration file: [/root/mynodebb/config.json].
    at File.loadSync (/root/mynodebb/node_modules/nconf/lib/nconf/stores/file.js:141:13)
    at Provider.add (/root/mynodebb/node_modules/nconf/lib/nconf/provider.js:135:23)
    at Provider.file (/root/mynodebb/node_modules/nconf/lib/nconf/provider.js:61:15)
    at start (/root/mynodebb/app.js:78:8)
    at Object.<anonymous> (/root/mynodebb/app.js:67:2)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)

    and my config.json file is

    "base_url": "”,
    "port": "4567",
    "use_port": true,
    "secret": "XXXXXX",
    "bind_address": "",
    "database": "redis",
    "redis": {
    "host": "",
    "port": "6379",
    "password": "",
    "database": "0"
    "bcrypt_rounds": 12,
    "upload_path": "/public/uploads",
    "relative_path": ""

  • GNU/Linux Admin

    Hm... that closing quote at the end of base_url doesn't look right... try replacing it with a regular quote: "

  • @julian it works fine with he ip address. I changed it, plugged in the url again and I'm back to an Error 502 screen.

  • GNU/Linux Admin

    The error in your console is basically saying that it cannot parse the file as it is not valid JSON. I'd recommend trying to run node app --setup if your editor is introducing errant characters into the config.json file...

  • @julian

    Yeah i just use dreamweaver ftp because it's quicker, for me at least. okay i got the website to run while the base_url is
    The facebook issue remains the same, although the app is no longer pinging the ip address.

    Okay. I just deleted the url and domain from facebook's app. Retyped it in again. Hit save. Now it works. this would be rewarding if i knew why that solved it.

  • GNU/Linux Admin

    Nice πŸ˜„

    I'm just glad it's working. I'm guessing your dreamweaver doesn't insert a plain ol' quote? Seems like an odd thing for a code editor to not do, but I'll refrain from making any disparaging remarks against that IDE πŸ˜„

    Edit: @kevin, can we possibly feature your forum on our main website?

  • I was editing them in plain document mode. That was my bad. It didn't seem to make a difference. The endquote worked fine when we had the ip in the base url.

    And yeah! of course! I'm glad you like it.

Suggested Topics

| | | |