@jw-sbat Always make sure the plugins you are using are working fine before deploying to production. Even if the plugin doesn't specify compatibility directly it could still work. That property specifies a minimum nodebb version.
NodeJS 4.0 released
Node is now also following semver, meaning it should be painless to upgrade to any version except a major version bump.
Xiph last edited by
Hmm, tried on a fresh install, but lwip wouldn't build for me.
Most likely this would be because all native modules need to be updated for 4.0.
Quoting from a blog post:
Recent changes to V8 which are included in io.js v3 are much more profound and require not only a newer version of NAN but a breaking API change in NAN itself which requires code changes in all dependent native modules.
(NAN = Native Abstractions for Node)
Some modules are already compatible though, as the same version of NAN is used by both io.js v3 and Node.js v4 and io.js v3 has been out for a while, so module authors had some time in advance of v4 to upgrade.
Other than lwip everything seems to be working, I removed lwip temporarily and booted on 4.0.0
@baris How to solve problems with mmmagic?
root@xen:/var/www# ./nodebb upgrade 1. Bringing base dependencies up to date... OK 2. Updating NodeBB data store schema. module.js:355 Module._extensions[extension](this, filename); ^ Error: Module did not self-register. at Error (native) at Module.load (module.js:355:32) at Function.Module._load (module.js:310:12) at Module.require (module.js:365:17) at require (module.js:384:17) at Object.<anonymous> (/var/www/node_modules/mmmagic/lib/index.js:3:13) at Module._compile (module.js:434:26) at Object.Module._extensions..js (module.js:452:10) at Module.load (module.js:355:32) at Function.Module._load (module.js:310:12) Error: undefined
I got rid of that with
npm r mmmagic
npm i mmmagic
@baris I wish I could get rid of the mmmagic dependency, but all the popular plugins out there deduce mime-type via file extension, and not magic numbers, so that's not really secure enough
... and every SO question I find tells me to use mmmagic
Using NodeJS 4.1 and NodeBB v0.8.x builds just fine except for
% node -v && npm -v v4.1.1 2.14.4
firstname.lastname@example.org without error. Would it be easy to make NodeBB depend on the later ? In case it helps here is the output once built.
email@example.com node_modules/lwip ├── firstname.lastname@example.org ├── email@example.com └── firstname.lastname@example.org (email@example.com)
Once this version of
lwipinstalled, NodeBB starts without problem. By the way, I love what you have done with the look and feel of the dashboard.
PS : I am on FreeBSD so I use clang to compile but I do not think it matters in that case.
NodeBB no longer depends on lwip, so you can ignore it
@julian That's a good news. Yet I am confused. Why does it need it when doing a fresh install (last time I checked with v0.8.x was one hour ago)?
Ah, that may be something only v0.9.x (not yet released) has
Just a cautionary note, don't try 4.x in prod yet...