Clear cache after 0.8.0 upgrade & can NOT login

Technical Support
  • Good day, Before I do a server rollback.
    Just wanted to check

    I upgraded to 0.8.0 last night everything went ok.
    Was able to log out and log back in.

    This morning I am getting the following error

    Failed login attempt, please try again.
    Cannot set property 'user' of undefined

    Ok, last night I did the upgrade from my laptop.
    This morning I tried to login from my desktop and received this error.

    Thought ok reset password.. still same issue.
    Then was like ok maybe a caching issue cleared the cache on my desktop still same thing.

    Then I was like hummm.. try the laptop.. Ok, it was working fine.. I logged out and in a few times.
    Then again, I was like humm. So I cleared the cache and it has broken it .. Reciving the same error.

    Anyone have any thoughts?
    Don't want to restore and have the same thing happen again.

  • OK did a roll back

    Then did the upgrade again
    Then cleared cache
    And low and behold, I can NOT login, nor any other user.. Had someone else check it

    My steps...

    thomasfraley@nodebb:~/nodebb$ clear
    thomasfraley@nodebb:~/nodebb$ git fetch

    remote: Counting objects: 1896, done.
    remote: Compressing objects: 100% (152/152), done.
    remote: Total 1896 (delta 1175), reused 1104 (delta 1102), pack-reused 642
    Receiving objects: 100% (1896/1896), 329.71 KiB | 0 bytes/s, done.
    Resolving deltas: 100% (1495/1495), completed with 229 local objects.
    944fc6e..f7648c2 v0.7.x -> origin/v0.7.x

    • [new branch] acp-paper -> origin/acp-paper
      a990e9c..a1fb234 master -> origin/master
    • [new branch] persona-2.1 -> origin/persona-2.1
      a1f49f6..0c62b0a v0.6.x -> origin/v0.6.x
      4f57227..796cf1b v0.8.x -> origin/v0.8.x
    • [new tag] v0.8.0 -> v0.8.0

    thomasfraley@nodebb:~/nodebb$ git checkout v0.8.x
    Branch v0.8.x set up to track remote branch v0.8.x from origin.
    Switched to a new branch 'v0.8.x'

    thomasfraley@nodebb:~/nodebb$ git merge origin/v0.8.x
    Already up-to-date.

    thomasfraley@nodebb:~/nodebb$ git pull
    Already up-to-date.
    thomasfraley@nodebb:~/nodebb$ ls
    app.js Dockerfile loader.js nodebb.bat public
    bcrypt.js Gruntfile.js logs node_modules
    config.json install minifier.js npm-shrinkwrap.json src LICENSE nodebb package.json tests

    thomasfraley@nodebb:~/nodebb$ ./nodebb upgrade

    1. Bringing base dependencies up to date... OK

    2. Updating NodeBB data store schema.
      Warning: Redis server does not require a password, but a password was supplied.
      Warning: Redis server does not require a password, but a password was supplied.
      Warning: Redis server does not require a password, but a password was supplied.
      28/8 07:26 [1240] - info: Beginning database schema update
      28/8 07:26 [1240] - info: [2015/02/08] Clearing reset tokens skipped
      28/8 07:26 [1240] - info: [2015/02/17] renaming home.tpl to categories.tpl skipped
      28/8 07:26 [1240] - info: [2015/2/23] Activating NodeBB Essential Rewards - skipped
      28/8 07:26 [1240] - info: [2015/02/24] Upgrading plugins:active to sorted set skipped
      28/8 07:26 [1240] - info: [2015/02/24] Upgrading privilege groups to system groups skipped
      28/8 07:26 [1240] - info: [2015/02/25] Upgrading menu items to dynamic navigation system skipped
      28/8 07:26 [1240] - info: [2015/05/07] Upgrading uid mappings to sorted set skipped
      28/8 07:26 [1240] - info: [2015/05/08] Fixing emails skipped
      28/8 07:26 [1240] - info: [2015/05/11] Updating widgets to tjs 0.2x skipped
      28/8 07:26 [1240] - info: [2015/05/20] Adding username:sorted and email:sorted skipped
      28/8 07:26 [1240] - info: [2015/06/02] Creating group sorted sets skipped
      28/8 07:26 [1240] - info: [2015/07/03] Enabling default composer plugin skipped
      28/8 07:26 [1240] - info: [2015/08/18] Creating children category sorted sets
      28/8 07:26 [1240] - info: [2015/08/18] Creating children category sorted sets done
      28/8 07:26 [1240] - info: [upgrade] Schema update complete!

    3. Storing upgrade date in "package.json"... OK

                           NodeBB Upgrade Complete!

    thomasfraley@nodebb:~/nodebb$ ./nodebb start

    Starting NodeBB
    "./nodebb stop" to stop the NodeBB server
    "./nodebb log" to view server output
    "./nodebb restart" to restart NodeBB


  • @tfraley What SSO plugins have you installed?

    As of...

    • an hour ago, I fixed a regression in the sso-google plugin that caused logins to break.
    • yesterday, I also fixed the 2factor plugin

    Those are the only two plugins that I am aware of, that were not compatible with v0.8.0 right out of the box.

  • @julian

    Ok here is the list of plugins I have installed


  • Can you install sso-google instead of sso-google-confirmed? I do not maintain that one, so I cannot resolve it (although let me open a PR now...)

  • @julian
    Ok uninstalled old google and installed and activated the new one now on last steps up upgrade again..

    That seems to have done it.


  • PR drewdotpro/nodebb-plugin-sso-google-confirmed#1, waiting on @drew, 😄

    afaik the only difference is these SSO users are insta-validated, which the other SSO plugins do not do.

  • @julian yeh I think now I know nodebb a bit better I can probably make a PR for the official one to allow insta-validate as a flag in the admin config for the plugin.
    Appreciate the PR

  • @julian does this apply to the facebook one too?

  • Current package updated to include PR from Julian and latest changes from his master

  • @drew Nope, just the Google one.

  • @julian
    Twitter SSO pplugins has also problem on 0.8.0

    Internal error. 
    Oops! Looks like something went wrong!
    Cannot set property 'user' of undefined
  • Ok guys, seems (from my low knowledge about auth) that since 0.8.0 only oauth2 is used ? and I think before it was not mandatory and was working because I didn't changed anything on auth provider (google, twitter, FB) between the upgrade on 0.7.3 to 0.8.0

    So after log investigation I get back on all app config, not it nodebb but on external application for developer on google, twitter, facebook and adjusted settings :

    • on FB dev page I added my email and enabled visibility to anyone => now Works
    • on google dev dashboard I enabled google+ API (it was working without this before, strange) => now works
    • I also changed into nodebb config.json url from to (even if nginx redirect all http to https) and solved my twitter problem

    Now all seems to auth fine, yeah!!

  • Hi there,
    Sorry I did not updated this post, but it worked fine until expiration of my token (not sure ??)
    I openned a new topic because I' could not log in anymore on my forum,
    Any ideas would save me 😉

Suggested Topics

  • Cache refresh

    Unsolved Technical Support
    0 Votes
    4 Posts

    Thank you, that works perfectly. In most cases something like this is much better handled through the write API. However in this instance, due to the large number of updates, it was much more efficient to process them through a script (roughly 50x faster).

  • 0 Votes
    3 Posts

    Yes! That's it, didn't realised grunt was setup in a way to pick-up custom themes. It's working like a charm!

    Thanks a lot @PitaJ !

  • 0 Votes
    13 Posts

    There's no way to expose HTTPS without a reverse proxy. This was a conscious decision to keep a separation of concerns, reduce development overhead, because reverse proxies have better support, and because anyone running multiple instances will need one for load balancing anyways.

    Nginx is quite easy to set up, and LetsEncrypt has very good support for it.

  • 0 Votes
    2 Posts

    Ah, yes, that is potentially a stumbling block... port property is optional, if not specified, NodeBB will listen on port 4567. However the url property is the one that is referenced by NodeBB, and is used as the canonical reference to itself... so when somebody asks your forum what it is to be called, NodeBB will respond back with the value in url, so the port is required if you are accessing your forum with port number in url.

  • 0 Votes
    3 Posts

    Not my browser, its a friends computer 🙂 But i will tell him 😛