• Hello,

    I tried all @fakhrullah "npm" commands to upgrade 0.7.0 to 0.7.3 : perfect !

    Thanks a lot ! 👍

  • Love NodeBB, love the new release approach and love the new package policy.

  • @drew said:

    Love NodeBB, love the new release approach and love the new package policy.

    I love NodeBB too, I just search the best GUI for Redis !!!


  • GNU/Linux

    @julian said:

    If you are a @3rd-Party-Developers, and your plugin does not have nbbpm.compatibility in its package.json, your plugin will no longer appear in ACP/Plugins

    Returning from a break and wondering where all those plugins went. xD
    Love it, though.

  • Good to know, i am helping. I always afraid to write something, in case i'm wrong. Now I know, I am Genius. 😄

  • Hello there,

    just upgraded to v0.7.3 first tried

    ./nodebb stop
    git pull
    ./nodebb upgrade

    but was still in v0.7.2 so

    ./nodebb stop
    git checkout v0.7.3
    ./nodebb upgrade

    then start and I'm on V0.7.3 but my homepage is broken is the fefault is to recent with this error

    28/8 03:26 [2239] - error: /
     TypeError: Object #<Object> has no method 'recent'
        at Controllers.home (/usr/local/share/nodebb/src/controllers/index.js:45:27)
        at Layer.handle [as handle_request] (/usr/local/share/nodebb/node_modules/express/lib/router/layer.js:95:5)
        at next (/usr/local/share/nodebb/node_modules/express/lib/router/route.js:131:13)
        at /usr/local/share/nodebb/src/middleware/middleware.js:74:3
        at Object.async.each (/usr/local/share/nodebb/node_modules/async/lib/async.js:118:20)
        at middleware.pluginHooks (/usr/local/share/nodebb/src/middleware/middleware.js:70:8)
        at Layer.handle [as handle_request] (/usr/local/share/nodebb/node_modules/express/lib/router/layer.js:95:5)
        at next (/usr/local/share/nodebb/node_modules/express/lib/router/route.js:131:13)
        at middleware.pageView (/usr/local/share/nodebb/src/middleware/middleware.js:62:4)
        at Layer.handle [as handle_request] (/usr/local/share/nodebb/node_modules/express/lib/router/layer.js:95:5)

    how can I fix it this point ?

    also nobebb says last version is v0.8.0 but not found any information on this announcement ? can I safe upgrade ?

  • Ok guys, self answer after v0.8.0 upgrade,

    I must admit this this the 1st no pain upgrade that I ever done with nodebb (each time took me hours to solve upcoming problems and re install all), but this time, it was a success and solved my previous issue. Here what I've done for interested people

    cd /usr/local/share/nodebb
    ./nodebb stop
    cd ..
    cp -r nodebb/ nodebb_old
    cp /var/lib/redis/dump.rdb /var/lib/redis/dump.rdb.bak
    cd nodebb
    git fetch
    git checkout v0.8.x
    git merge origin/v0.8.x #(nothing done already up to date)
    git pull #(nothing done already up to date)
    ./nodebb upgrade
    ./nodebb start

    and voila! works fine

  • NodeBB

    @Charly86 In those steps you should stop nodebb and then copy the redis dump, so that the changes are saved to the file.

  • @baris
    I ever don't know how I missed that one, you're absolutly right 😉 I updated the post according to this error!

  • This post is deleted!

Suggested Topics

| |