Most likely there weren't any major breaking changes for plugins between those two versions. You should be okay to upgrade, although I'd back up your database just to be safe.
NodeBB Plugin-Mentions out of date?
I tried updating the nodebb-plugin-mention to v1.0.0. However upon upgrading my entire site crashed.
The logs said this
[outdated] nodebb-plugin-mentions v1.0.0, requires ^0.11.7
Is there a way to update my requirements for these plugins? I have a couple other plugins that I haven't been able to upgrade as well
Same thing happened to my site. The requirement is
^0.11.7, which means it wants a version that is equal to or greater than
0.11.7but less than
So it considers
Either there is a change in
1.0.0that breaks your version of NodeBB, or they forgot to change the version dependency.
Just installing the older version should work until they fix it.
npm i firstname.lastname@example.org
Either there is a change in 1.0.0 that breaks your version of NodeBB
However upon upgrading my entire site crashed.
Yep. It's 1.0.0 because it contains a breaking change that v0.7.2 cannot handle. I know the upgrade button is awfully enticing, but hold off until v0.7.3 is released
Yes I do also realise that we shouldn't show the upgrade button if the compatibility check fails...