I am stuck on Step 5 through 7 of Installation using MongoDB

Solved Technical Support
  • Hello, everybody!

    During my installation, I had issues with Step 5, 6, and 7 that are listed here on the manual:

    1. I tried to follow this:

    Step 5 and 6.PNG

    Then I got this:

    trying to install nodebb dependencies.png

    Should I ignore the warning? Why it says "Killed"?

    1. I proceed after those warning, then went on Step 7.

    That is where I got stuck.

    Step 7.PNG

    First of all, do I run $ mongo in the current directory, or I have to go to my home directory then run it? I did the latter. Then I went to the other step of :# nano /etc/mongodb.conf then couldn't figure out how to modify the file as they say on the manual.

    I got the following screen when I ran : sudo nano /etc/mongodb.conf

    couldn't modify.PNG

    Can someone help? Thanks

  • I would try reinstalling MongoDB if possible...

  • As @markkus said, it seem that your mongodb installation has not completed normally. I would reinstall mongo too. The file /etc/mongodb.conf should contain text with configuration of the database server. As it is empty it seems not installed properly.

    You could try first to setup nodebb without mongodb authentication and then enabling it, editing the mentioned file, and the configuration file of nodebb.

  • Thank you @markkus and @jarey for your replies. I did what you suggested about re-installation and the problem persisted. I then discovered something...

    ...the installation manual may be outdated. The file in question on Step 7 is mongod.conf instead of mongodb.conf.

    Step 7 Corrected.png


    Can @psychobunny or whoever in charge of the Doc double check this and make the proper correction?

Suggested Topics

  • 0 Votes
    3 Posts
  • 0 Votes
    4 Posts
  • 0 Votes
    8 Posts
  • 0 Votes
    72 Posts
  • 0 Votes
    7 Posts