• @julian
    When issuing the "npm i" command i recieved this error
    npm ERR! peerinvalid The package nodebb-theme-vanilla does not satisfy its siblings' peerDependencies requirements!
    npm ERR! peerinvalid Peer nodebb-plugin-spam-be-gone[email protected] wants [email protected]>=0.0.137
    npm ERR! peerinvalid Peer [email protected] wants [email protected]~0.0.13

    npm ERR! System Linux 3.16.0-28-generic
    npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "i"
    npm ERR! cwd /root/nodebb
    npm ERR! node -v v0.10.25
    npm ERR! npm -v 1.4.21
    npm ERR! code EPEERINVALID
    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR! /root/nodebb/npm-debug.log
    npm ERR! not ok code 0

    Would I require to reset all my plugins?

  • GNU/Linux Admin

    @MySelfLuls Cerulean is quite out of date, I wouldn't recommend installing it.

    npm unlink nodebb-plugin-cerulean

    Then try again.


  • @julian
    Thanks a lot.
    Btw.
    What was added in the newest update?

  • GNU/Linux Admin


  • @julian Followed latest instructions in this post, got this.

    Error: Cannot find module './styles'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/home/errapolis/nodebb/node_modules/colors/lib/colors.js:36:34)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    
  • GNU/Linux Admin

    Seems like the colors module wasn't installed properly... try reinstalling it? npm i colors


  • I knew i'd encountered a problem like that before, that worked, though subsequently I ran upgrade then it was the same issue with "cookie", then upgrade, then "crc", now "debug". Is there a quicker way to find all those needed if more follow?


  • @julian would this bunch be causing the problem now that the dependency requirements are more strict?

    unmet.JPG

    If so, any hints? Stuck on this:

    Capture.JPG

  • GNU/Linux Admin

    @Danny-McWilliams Nope, that should only apply to bundled plugins (mentions, vanilla/lavender/persona theme, markdown, etc).

    If you're getting more of those "cannot find module" errors, then perhaps your dependencies were not completely installed.

    Please run npm install.


  • Ok @julian just did - same result, sadly. unmet dependency list then the same as the second picture.

    Tried to start nodebb, this was in log.

    Capture.JPG

  • GNU/Linux

    @julian i run ./nodebb upgrade after it looks successful npm i command ?

    ./nodebb upgrade
    
    module.js:340
        throw err;
              ^
    Error: Cannot find module 'ini'
        at Function.Module._resolveFilename (module.js:338:15)
        at Function.Module._load (module.js:280:25)
        at Module.require (module.js:364:17)
        at require (module.js:380:17)
        at Object.<anonymous> (/root/nodebb/node_modules/npm/node_modules/config-chain/index.js:4:11)
        at Module._compile (module.js:456:26)
        at Object.Module._extensions..js (module.js:474:10)
        at Module.load (module.js:356:32)
        at Function.Module._load (module.js:312:12)
        at Module.require (module.js:364:17)
    
    21/7 20:21 [25890] - error: Error: Cannot find module './build/Release/magic'
        at Function.Module._resolveFilename (module.js:338:15)
        at Function.Module._load (module.js:280:25)
        at Module.require (module.js:364:17)
        at require (module.js:380:17)
        at Object.<anonymous> (/root/nodebb/node_modules/mmmagic/index.js:3:13)
        at Module._compile (module.js:456:26)
        at Object.Module._extensions..js (module.js:474:10)
        at Module.load (module.js:356:32)
        at Function.Module._load (module.js:312:12)
        at Module.require (module.js:364:17)
    Error: Cannot find module './build/Release/magic'
        at Function.Module._resolveFilename (module.js:338:15)
        at Function.Module._load (module.js:280:25)
        at Module.require (module.js:364:17)
        at require (module.js:380:17)
        at Object.<anonymous> (/root/nodebb/node_modules/mmmagic/index.js:3:13)
        at Module._compile (module.js:456:26)
        at Object.Module._extensions..js (module.js:474:10)
        at Module.load (module.js:356:32)
        at Function.Module._load (module.js:312:12)
        at Module.require (module.js:364:17)
    
    module.js:340
        throw err;
        ^
    Error: Cannot find module './build/Release/magic'
        at Function.Module._resolveFilename (module.js:338:15)
        at Function.Module._load (module.js:280:25)
        at Module.require (module.js:364:17)
        at require (module.js:380:17)
        at Object.<anonymous> (/root/nodebb/node_modules/mmmagic/index.js:3:13)
        at Module._compile (module.js:456:26)
        at Object.Module._extensions..js (module.js:474:10)
        at Module.load (module.js:356:32)
        at Function.Module._load (module.js:312:12)
        at Module.require (module.js:364:17)
    
  • GNU/Linux

    npm i is your phriend

    NodeBB Upgrade Complete!

  • Community Rep

    @Danny-McWilliams said:

    Ok @julian just did - same result, sadly. unmet dependency list then the same as the second picture.

    Tried to start nodebb, this was in log.

    Capture.JPG

    Usually when I get issues like this, I have to do an npm cache clean and then an npm install or npm rebuild

  • GNU/Linux

    for some reason my ./nodebb upgrade script after git pull missed a ton of modules


  • trying to update, but npm i shows me that

    npm WARN unmet dependency /home/leksar/nodebb/node_modules/nodebb-plugin-shoutbox requires [email protected]'~0.2.9' but will load
    npm WARN unmet dependency /home/leksar/nodebb/node_modules/async,
    npm WARN unmet dependency which is version 0.9.2
    npm WARN unmet dependency /home/leksar/nodebb/node_modules/nodebb-plugin-shoutbox requires [email protected]'~1.8.0' but will load
    npm WARN unmet dependency /home/leksar/nodebb/node_modules/string,
    npm WARN unmet dependency which is version 3.3.0
    npm ERR! peerinvalid The package nodebb-theme-vanilla does not satisfy its siblings' peerDependencies requirements!
    npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.0.137
    npm ERR! peerinvalid Peer [email protected] wants [email protected]~0.0.18
    
    npm ERR! System Linux 3.16.0-43-generic
    npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "i"
    npm ERR! cwd /home/leksar/nodebb
    npm ERR! node -v v0.10.25
    npm ERR! npm -v 1.3.10
    npm ERR! code EPEERINVALID
    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/leksar/nodebb/npm-debug.log
    npm ERR! not ok code 0
    

    Tried to do npm unlink nodebb-plugin-spam-be-gone and npm unlink nodebb-theme-ifsta-ui, but the result is the same. Any ideas ?

  • GNU/Linux

    try npm uninstall nodebb-theme-vanilla and then reinstall it again, it might install the version that satisfies the dependancy.

    Save changes made to vanilla too if need be ๐Ÿ™‚


  • same result

  • GNU/Linux

    @leksar try run ./nodebb upgrade
    paste error from [email protected] ?


  • [email protected]:~/nodebb$ sudo ./nodebb upgrade
    [sudo] password for leksar:
    no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory
    1. Bringing base dependencies up to date
    
    Error: The package [email protected] does not satisfy its siblings' peerDependencies requirements!
    
  • GNU/Linux

    sounds like unlinking those plugins did nothing.

    I'm out of idea's but that was why it was complaining, maybe uninstall them if they aren't vital

    I dont use shoutbox or that other thingo

Suggested Topics

| |