User search error 0.7.0 master


  • Plugin & Theme Dev

    Updated to latest in master this evening.

    When searching for user in ACP/site I get the following error popup:
    ERR unknown command 'zrangebylex'
    http://forum.mysensors.org/users/search

    Which also occurs when trying to assign users to groups etc.
    Tried reindex search database but with no luck.

    We're also experice old-theme-artifacts in Crome like reported earlier here. Only effective way is to have all users do a full cache clear (ctrl-shit-r does not work).

    Not so good.



  • I will up our required redis version to 2.8.9 since that command is added there. Can you upgrade your redis?


  • Plugin & Theme Dev

    you mean doing a
    npm install redis@2.8.9
    ?



  • No the actual redis database version. So you need to install it with your OS package manager etc.


  • Plugin & Theme Dev

    Ok, will do. Thanks.


  • Plugin & Theme Dev

    Strange updated redis but still see the problem:

    ~/mysensors-forum/NodeBB$ dpkg -s redis-server
    Package: redis-server
    Status: install ok installed
    Priority: optional
    Section: database
    Installed-Size: 868
    Maintainer: Chris Lamb <lamby@debian.org>
    Architecture: amd64
    Source: redis
    Version: 3:3.0.1-1chl1~trusty1
    Depends: libc6 (>= 2.14), libjemalloc1 (>= 2.1.1), redis-tools (= 3:3.0.1-1chl1~trusty1), adduser
    Conffiles:
     /etc/init.d/redis-server 387b03762e0cf0db194e961104137b5a
     /etc/default/redis-server 45e997df22f4c5c2b5c9ae159775a089
     /etc/redis/redis.conf cfd6d515329a5af408ab286707413a0e
     /etc/logrotate.d/redis-server 06755b99ef70d62a56cff94cbfc36de7
     /etc/redis/sentinel.conf a95ae9b0242a03c5b4dd1af934478895 obsolete
    Description: Persistent key-value database with network interface
     Redis is a key-value database in a similar vein to memcache but the dataset
     is non-volatile. Redis additionally provides native support for atomically
     manipulating and querying data structures such as lists and sets.
     .
     The dataset is stored entirely in memory and periodically flushed to disk.
    Homepage: http://redis.io/
    
    

    Too late to fix it here tonight. But would appriciate any ideas how to resolv it.



  • Check if the version is updated through redis-cli.

    redis-cli
    >info server
    # Server
    redis_version:2.8.12
    
    

  • Plugin & Theme Dev

    @baris said:

    info server

    Hm....

    $ redis-cli 
    127.0.0.1:6379> info server
    # Server
    redis_version:2.8.4
    

    So, am I missing something here? Isn't it enough to update the "redis-server" package?

    Getting a different version when doing:

    >/usr/bin/redis-server -v
    Redis server v=3.0.1 sha=00000000:0 malloc=jemalloc-3.6.0 bits=64 build=3eaa8bd2bf3dd763
    hek@stage:~$
    

    What a mess...


  • Plugin & Theme Dev

    Guess I was tired last night. Redis server hadn't been restarted after upgrade. 😳



  • @hek said:

    Guess I was tired last night. Redis server hadn't been restarted after upgrade. 😳

    Haha yeah would be why.


Log in to reply
 

Suggested Topics

  • 2
  • 13
  • 5
  • 9
  • 6
| |