login forbidden, even for admin

Technical Support
  • Hello,

    My nodebb forum was running fine for a while. Today suddenly i noticed no new users signed up and the latest posts and latest topics widgets where suddenly missing on my forum.

    When i tried to login (both with my admin account as a random user account) a new windows opens with only the word "forbidden"

    When i look through terminal access i see the following:

    ./nodebb status
    NodeBB is not running

    ./nodebb log
    at Server._listen2 (net.js:1042:14)
    at listen (net.js:1064:10)
    at Server.listen (net.js:1138:5)
    at module.exports.listen (/home/xxx/nodebb/nodebb/src/webserver.js:177:18)
    at /home/xxx/nodebb/nodebb/node_modules/async/lib/async.js:656:23
    at fn (/home/xxx/nodebb/nodebb/node_modules/async/lib/async.js:641:34)
    at Object._onImmediate (/home/xxx/nodebb/nodebb/node_modules/async/lib/async.js:557:34)
    at processImmediate [as _immediateCallback] (timers.js:345:15)
    16/5 20:07 [21984] - error: NodeBB address in use, exiting...
    [cluster] Child Process (21984) has exited (code: 0, signal: null)

    So it says nodebb address is in use, but looking at the status it is not running. Although it is not running following the status command the forum itself when i visit the url is working fine (only the login and widget problem)

    When i try to start it it looks to start normal:

    ./nodebb start
    Starting NodeBB
    "./nodebb stop" to stop the NodeBB server
    "./nodebb log" to view server output

    but when i check it still says its not running.

    When i start in dev mode i get the same as the log mode only with a few more plugin warnings and other warnings like:

    • Warning: Redis server does not require a password, but a password was supplied.
    • warn: [plugins/nodebb-plugin-mentions] This plugin may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing.

    As i said my forum was running fine. I did not install anything the last days. Anyone have any idea what is wrong?



  • Oh one more thing. In my nodebb admin i always see a warning message saying something like: your forum is in development mode

    Is there something i can do to change this? I just installed in through terminal with the links provided on the official nodebb website.

    i cant place the complete warning message here as i am not able to enter the admin anymore due to the login problems

  • Here's your problem:

    NodeBB address in use, exiting...

    You need to shut down whatever is using that port. The other warnings / messages are unrelated

  • how can i check if its nodebb which is running on that port as i think it must be nodebb as the forum is still live een while it says nodebb isnt running...maybe it got stuck or something.

    nothing else is running on that port as i use a seperate port for nodebb which isnt run by any other program....i do run it with nginx but that isnt related i guess

  • For linux, you can use netstat and kill. Ex:

    yari@yaricraft:~$ netstat -tulnp | grep "4567"
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0  *               LISTEN      5534/nodejs
    yari@yaricraft:~$ kill 5534
  • i check and it was nodebb which was running there:

    netstat -tulnp | grep "4567"
    tcp 0 0* LISTEN 30507/node

    i tried rebooting my system, then i was able to restart nodebb fine.

    The same login problem is there but i saw a new error: invalid csrf token

    Done sofar:

    1. tried changing to http://sitename.com:4567 in my nginx config

    2. service nginx stop
      rm -rf /var/cache/nginx/
      mkdir /var/cache/nginx/
      service nginx start

    3. restarting reddis, which was running fine

    this is my config.json file:

    "url": "http://www.sitename.com",
    "secret": "xxx",
    "database": "redis",
    "redis": {
    "host": "",
    "port": "6379",
    "password": "",
    "database": "0..n"
    output of npm ls nodebb-theme-vanilla nodebb-theme-lavender:

    [email protected]
    [email protected]

    nodebb version: 0.7.0-dev

  • now the error is gone but my complete forum is down ๐Ÿ˜ž

    • nodebb is running (no errors only a few plugin warnings)
    • nodebb is up2date
    • redis is running
    • nginx is running fine (all other sites on server are running fine as well)

    when i check my site it says: 502, bad gateway
    when i check ip:4567 (no connection)

    ranning out of ideas here ๐Ÿ˜ž

Suggested Topics