[nodebb-plugin-calendar] Fully featured calendar plugin for NodeBB - Testers needed


  • Global Moderator

    @yariplus

    Alright. I think it's fixed. Try it now.


  • Community Rep

    @pitaj Almost 😉

    It works on cold load, but not on ajaxing.

    Looks like it's because the widget areas are not loaded yet at the time you do the detach/append:

          console.log('Widget Area Exists: ' + !!$('[widget-area="sidebar"]').length);
          var cal = $("#nodebb-plugin-calendar").detach();
          $("#content").empty().append(cal);
    
    "Successfully loaded initial data" nodebb.min.js:979:8
    "Widget Area Exists: false" nodebb.min.js:1009:0
    "Calendar templates loaded" nodebb.min.js:1002:8
    

  • Global Moderator

    @yariplus that must be because the document ready event is allready done when ajaxify does stuff.

    Hmmmm...



  • Mine gets cut off for some reason.
    Also, is it supposed to auto post to Announcements?

    upload-a95e4e2b-edd5-4f5b-b715-97a149c6062a


  • Global Moderator

    @rhistina you're supposed to configure the correct category in the settings page in the ACP



  • @pitaj Thanks! Also do you have any screenshots of what it should look like when it auto posts to the category you want? Mine looks like below. Also note that I'm a total noob to NodeBB and I have no idea what I'm doing :D! So I apologize in advanced for asking questions that may seem otherwise obvious.

    upload-faa5aff7-43cd-4c14-b2f3-4e37db317bfa


  • Global Moderator

    @rhistina yeah, right now it just looks like that. I'm working on getting that to work.

    Do you have this on a publicly available server?

    Also, about that cut off thing. Can you tell me what theme you're using and the output of typing the following command in the JavaScript console:

    $("#content").children()
    

    Thanks



  • Can you explain how the privledges work, it seems a bit confusing to me, can anyone create an event or only the group you assign in the admin panel? I can't create an event even though i've assigned the moderator group access.. I just get "no privledge" error in nodebb dev

    Maybe i have done something wrong... looks good though


  • Global Moderator

    @chas the global privileges are set up in the plugin settings page in the ACP. I tried to make that setup the category permissions automatically, but it may not work perfectly. Check the permissions for the category, and make sure the use has permissions to post in it.



  • I think anything i put into the ACP calendar permissions crashes. I add the "Staff" group i made to all three Global privledges, and choose 4 as the category i want to post the event under.

    Im running latest Master pulled today. and as soon as i click "Save Changes" on the Calendar settings i get this in the dev log

    15/5 12:28 [23010] - warn: Route requested but not found: /uploads/av-1323.png
    15/5 12:30 [23010] - error: TypeError: Cannot call method 'replace' of undefined
    at parse (/home/chas/nbb/nodebb/node_modules/nodebb-plugin-emoji-extended/index.js:1:6612)
    at Object.module.exports.parse [as method] (/home/chas/nbb/nodebb/node_modules/nodebb-plugin-emoji-extended/index.js:1:7006)
    at /home/chas/nbb/nodebb/src/plugins/hooks.js:89:12
    at /home/chas/nbb/nodebb/node_modules/async/lib/async.js:272:13
    at iterate (/home/chas/nbb/nodebb/node_modules/async/lib/async.js:149:13)
    at /home/chas/nbb/nodebb/node_modules/async/lib/async.js:160:25
    at /home/chas/nbb/nodebb/node_modules/async/lib/async.js:274:17
    at Object.Markdown.parseRaw [as method] (/home/chas/nbb/nodebb/node_modules/nodebb-plugin-markdown/index.js:105:5)
    at /home/chas/nbb/nodebb/src/plugins/hooks.js:89:12
    at /home/chas/nbb/nodebb/node_modules/async/lib/async.js:272:13
    [cluster] Child Process (23010) has exited (code: 1, signal: null)
    [cluster] Spinning up another process...


  • Global Moderator

    @chas the emoji extended plugin is causing an error for you. Try disabling that plugin and trying again.


  • Admin

    Somehow I forgot to respond to this. Very cool. This intrigues me:

    Support for (optionally) using arasbm's Whoisin plugin to power the response system

    Did you create your own hook or something? action:plugins.calendar.add or something like that?


  • Global Moderator

    @psychobunny no, I just detect if the who is in plugin exists, and if the user wants to use it, then I use it.

    The who is in plugin has an external method, so when I require it in the init method, I check for that and use it to do stuff.

    Come to think of it, I might not have it implemented yet in v0.2.0


  • Admin

    It'd be cool to have a hook like that so you personally don't have to maintain the code (and others can easily tap into your plugin)


  • Global Moderator

    @psychobunny

    er meh gerd, stop suggesting features 😠 :rage2:

    stop posting

    jk



  • @pitaj

    hahahhahahahahhahahahhaha 😆



  • @pitaj, category posts seem to use bbcode instead of markdown. The following is from a test event:

    
    
    [h1][/h1]
    
    [h3]When:[/h3]
    [strong]Starts:[/strong] [allday=false date=2015-05-29T01:00:00.000Z]
    [strong]Ends:[/strong] [allday=false date=2015-05-29T02:00:00.000Z]
    
    [h3]Location:[/h3]
    
    [hr][/hr]
    

    Additionally, groups specified don't persist after save changes is clicked:


  • Global Moderator

    @Guiri yes, I'm aware of the bbcode one. It's just a placeholder for now.

    The groups though, can you make an issue on Github for that. It's easier to track it that way. Thanks.



  • I got it on my install. Problems I'm having:
    -The above screenshots of it using bbcode
    -Said bbcode shows up in the calendar page
    -It goes to December 2014 sometimes when I open it. About 75 % of the time.
    upload-c052d622-822a-4822-b946-24f482295fea !



  • @pitaj I started testing your calendar today and there's several issues that have come up

    • Previously mentioned bbcode, both on the calendar and in the post it generates
    • Previously mentioned jump to random prior date
    • Events are not saving. I created an event on one account, but it is not visible on another, viewer settings were correct, errors everywhere.
    • Tons of errors popping up on the side, I'll look into it once I enable debug mode
    • Some errors while attempting to post, preventing me from posting events sometimes, I'm not sure what the reason for that is
    • The "topic tools" dropdown on the rightmost panel is blocked by the UI, I can't really see anything when trying to use it.

    I've only been using it for a short time so these are just some on the surface bugs, any chance of you tackling em any time soon?


Log in to reply
 

Suggested Topics

| |