• Gamers

    @julian said:

    Paste error logs! We can't help if you don't provide it.

    [email protected]:~$ cd nodebb
    [email protected]:~/nodebb$ ./nodebb stop
    Stopping NodeBB. Goodbye!
    [email protected]:~/nodebb$ git fetch
    remote: Counting objects: 5, done.
    remote: Compressing objects: 100% (5/5), done.
    remote: Total 5 (delta 0), reused 0 (delta 0), pack-reused 0
    Unpacking objects: 100% (5/5), done.
    From https://github.com/NodeBB/NodeBB
    b2f2561..d8e52d7 master -> origin/master
    [email protected]:~/nodebb$ git checkout v0.7.x
    error: Your local changes to the following files would be overwritten by checkou t:
    public/language/it/global.json
    public/language/it/groups.json
    Please, commit your changes or stash them before you can switch branches.
    Aborting


  • Please, commit your changes or stash them before you can switch branches.

    Easiest way is to run git stash then checkout again.

  • Gamers

    @a_5mith said:

    Please, commit your changes or stash them before you can switch branches.

    Easiest way is to run git stash then checkout again.

    npm ERR! Linux 3.13.0-43-generic
    npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install"
    npm ERR! node v0.12.2
    npm ERR! npm v2.7.4
    npm ERR! code EPEERINVALID

    npm ERR! peerinvalid The package nodebb-theme-vanilla does not satisfy its siblings' peerDependencies requirements!
    npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.0.137
    npm ERR! peerinvalid Peer [email protected] wants [email protected]^1.0.0
    npm ERR! peerinvalid Peer [email protected] wants [email protected]^0.2.0

    npm ERR! Please include the following file with any support request:
    npm ERR! /home/antonio/nodebb/npm-debug.log
    npm WARN package.json [email protected] No repository field.
    npm ERR! Linux 3.13.0-43-generic
    npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "i" "nodebb-theme-vanilla" "nodebb-theme-lavender" "nodebb-widget-essentials"
    npm ERR! node v0.12.2
    npm ERR! npm v2.7.4
    npm ERR! code EPEERINVALID

    npm ERR! peerinvalid The package nodebb-theme-vanilla does not satisfy its siblings' peerDependencies requirements!
    npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.0.137
    npm ERR! peerinvalid Peer [email protected] wants [email protected]^1.0.0
    npm ERR! peerinvalid Peer [email protected] wants [email protected]^0.2.0

    npm ERR! Please include the following file with any support request:
    npm ERR! /home/antonio/nodebb/npm-debug.log

    module.js:356
    Module._extensions[extension](this, filename);
    ^
    Error: /home/antonio/nodebb/node_modules/mmmagic/build/Release/magic.node: undefined symbol: node_module_register
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/home/antonio/nodebb/node_modules/mmmagic/index.js:3:13)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)


  • Update your themes with npm install [email protected] and npm install [email protected]

    Then see if there's an update for the spam-be-gone plugin the same way.

    Also remove the material theme as it's not compa table with npm rm nodebb-theme-material

  • Gamers

    @a_5mith
    Nothing.
    Don't work.

    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/home/antonio/nodebb/node_modules/mmmagic/index.js:3:13)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    3 restarts in 10 seconds, most likely an error on startup. Halting.
    

    If i do again ./nodebb upgrade , give this error.

    npm WARN package.json [email protected] No repository field.   
    npm WARN package.json [email protected] No repository field.
    [email protected] node_modules/nodebb-widget-essentials
    
    [email protected] node_modules/nodebb-theme-lavender
    
    [email protected] node_modules/nodebb-theme-vanilla
    27/5 10:48 [30551] - info: NodeBB v0.7.0 Copyright (C) 2013-2014 NodeBB Inc.
    27/5 10:48 [30551] - info: This program comes with ABSOLUTELY NO WARRANTY.
    27/5 10:48 [30551] - info: This is free software, and you are welcome to redistribute it under certain conditions.
    27/5 10:48 [30551] - info:
    
    module.js:356
    Module._extensions[extension](this, filename);
                               ^
    Error: /home/antonio/nodebb/node_modules/mmmagic/build/Release/magic.node: undefined symbol: node_module_register
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/home/antonio/nodebb/node_modules/mmmagic/index.js:3:13)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    

  • npm install mmmagic

  • Gamers

    @a_5mith said:

    npm install mmmagic

    Same error.

    module.js:356
    Module._extensions[extension](this, filename);
                               ^
    Error: /home/antonio/nodebb/node_modules/mmmagic/build/Release/magic.node: undefined symbol: node_module_register
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/home/antonio/nodebb/node_modules/mmmagic/index.js:3:13)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    
  • Anime Lovers

    also have got the same error...

  • GNU/Linux Admin

  • Gamers

    @julian
    Ubuntu node-v0.12.2 on 14.04

  • Anime Lovers

    @julian debian wheezy
    using latest node.js 0.12.x

  • GNU/Linux Admin

    Hm, no reason then, why mmmagic wouldn't compile. Do you both have build-essential installed?

  • Gamers

    @julian I think so.

  • Anime Lovers

    @julian This question..., really don't want to answer

  • Anime Lovers

    also note that npm install does not fail!

    ./nodebb upgrade
    

    throws this error

  • Gamers

    @wzrdtales said:

    also note that npm install does not fail!

    ./nodebb upgrade
    

    throws this error

    Please, help me. XD 😱 😭

  • Anime Lovers

    This also only happens with v0.12.x if you downgrade to v0.10.x, then npm rebuild to rebuild the modules, do the upgrade with v0.10.x and upgrade to v0.12.x again and again npm rebuild everything works...

    @julian something is completely wrong together with v0.12.x

Suggested Topics

| |